Toad World® Forums

Query plan of stored procedure execution.


#1

Is there any chance of having the full plan of the execution of a stored procedure rather than just

QUERY PLAN FOR STATEMENT 1 (at line 1).
STEP 1
The type of query is EXECUTE.

I have tried set showplan on against an ASE 12.5.3 server and I manage to display it in the message tab but there are to many extra empty lines.

With ASE 15.5 I don’t get much useful information either :

Query cost (relative to the batch): 0,00%
execute xp_liste_camion_carto ‘bprint’

ScreenShot167.jpeg


#2

Hello Jean-Pierre,

I created CR 81,413 to have this feature added to our query plan window.

As a workaround though, you can execute something like this in the editor and it will show the stored procedure plan in the messages tab.

use pubs2
go

DBCC TRACEON( 3604, 302 )
SET SHOWPLAN ON
SET FMTONLY ON
GO

exec byroyalty @percentage = 100
go


#3

Hello Michael,

I have tried what you suggested but the output I get doesn’t look as good as what you get. It looks like what I had in yesterday’s screenshot with all the extra blank lines.

Maybe you aren’t running the same version I am running.

I also noticed that you are executing a stored procedure with named parameters.

Does that mean that the issue with Sybase ADO.net has been resolved (case 11647711) ?


#4

Hello,

Your messages tab is in text output mode. To put the message back into data grid mode, right-click it and remove the check from the “Text Output” menu item.

Sybase has provided me with a workaround for the named parameters issue and it will be fixed in the next beta.

Thanks.
messages.png


#5

hi Michael,

could you elaborate please on the workaround for the named parameters issue?
Do you connect to Sybase through Sybase.AdoNet2.AseClient.dll?
Did Sybase provide you with any ETA for the beta fixing the reported problem?

Thanks,
Motty


#6

Hello Motty,

We use the latest Sybase.AdoNet2.AseClient.dll (ESD #8) to connect to ASE. In order to use named parameters you need to add ‘NamedParameters=false;’ to your connection string. This should not be the case as setting this value to false should disable the functionality and not enable it. In any case, I’ve been told that this will all be fixed in ESD #9 which should be out soon.

BTW, the next beta will use this workaround while we wait for a new driver.

Hope that helps.