Toad World® Forums

Quest SQL Optimzier for SQL Server Ver.9.0 issue


#1

After I installed Quest SQL Optimzier for SQL Server Ver.9.0 issue, I get this message whenever I open SSMS - “TypeLoadException: Could not load type ‘Microsoft.SqlServer.Management.SqlStudio.Explorer.ObjectExplorerService’…”.

Has anyone had the same issue like this?

Could you share with me how to fix it?

Thanks!


#2

I just tried installing SQL Optimizer 9.0 and it did not happen to me. I am running SQL Server Management Studio 2008 R2.


#3

I am using SSMS 2008. I just tried to uninstall and re-installed it, and the issue still persists.

Is it compatible with SSMS 2008?


#4

Can you tell us more details?

  1. What OS are you using?

  2. What version of Quest SQL Optimizer for SQL Server 9.0? commericial or trial?

  3. Was Quest SQL Optimizer for SQL Server 9.0 launched while you opened SSMS?


#5
  1. Windows 7 64-bit

  2. It’s commercial

  3. No, it is not launched.


#6

I found out the issue is come from the Toad for SQL Server 6.0.

If I uninstalled that, the message is gone.

Do you have any advice how to fix it?


#7

The issue was also posted in Toad for SQL Server Community. There is a hot fix for it.

www.toadworld.com/.../14915.aspx


#8

I copied all DLL files from the hot fix, but I still have the same issue.


#9

Budi, can you please advise if you are using SSMS 2008 R2?

Seems like you have 2008 NOT R2, so you should simply uninstall the plug-in by using this guide:

dev.toadforsqlserver.com/…/Default.htm

Toad has plug-in which integrates into ManStudio and help you to run Toad’s features from the context of ManStudio. There is support for 2012 and 2008R2 versions.