Toad World® Forums

Question on how to display data type and size on Entity object?



I am wondering how could I make the data type and size visible on the Entity Objects?
I used the previous release, it will display the data type and size automatically, I am not sure if i need to set anything on it to make this feature visible.

Please let me know if u need more information.

Many thanks



Hello Chi,

Data types are set to be displayed by default. So, if you didn’t change the settings (in Options or for your model), they should be displayed in all new models you create. Please see the Settings | Options | Physical (Logical) Model | Entity tab | Display Data Types.

For already existing models, you can set it up in the Workspace Format.

If you have any questions, please write me back. Thanks.





I have followed your instruction to make the data type visible, unfortunately, it does not work on my model. It works on a new model that I created.

I have attached an screen shot for you to make sure i do it correctly.

Please let me know if you want me to explain more

Many thanks

Problem.doc (338 KB)


Hello Chi,

Yes, what you define in Options will work for NEW models.

To change format in already existing models, you need to edit the Workspace Format.

To your screenshots:
In WS Format, I can see display level ‘Entities’. However, the entity of which Properties form you opened has display level ‘Attributes’ as its attributes are displayed. It means that format of this entity is different than format of WS.
In this case, if you edit WS Format, format of the entity remains untouched.

Solution A: Edit format of the particular entity: right-click the entity | Format | Entity tab | Display Data Types.
Solution B: - If you like to unify format of all entities in this WS. - CTRL + A to select all, right-click any | Format and define the format settings.

If you have any questions, please write me back. Thanks!

Vladka + TDM Team