Toad World® Forums

Recognize custom extensions as sql files


#1

Hi Guys

I want to use a .Prc extension to indicate stored procedures. How can I make Toad For Sybase recognize these files as stored procedure or even just SQL files? At the moment, they are recognized as neither and the syntax highlighting is all messed up.

Michael


#2

Any Ideas?


#3

Hi Michael,

as a matter of fact Toad does not recognize the files according to their extension but to their content.

But please, remember that you need to have an open connection and then Toad should parse the SQL file correctly.

Thanks,


#4

Hi Daniel

Thanks for responding, but this is not the behavior I see. I take a DDL file named myfile.Tbl and using windows, copy the file, naming the copy myfile.sql. Open myfile.Tbl in Toad for Sybase… no syntax highlighting. Open myfile.sql in Toad for Sybase… syntax highlighting. maybe something in my setup is funny?

Michael


#5

so 210 people have looked at this thread but nobody has an answer. I am concluding from this that it is not possible and that Toad is my least favorite editor.


#6

Hi Michael,

do you have the Default language set in Options | Editor | General?

I tested it and it seems to open for example *.tbl files correctly.


#7

Aha! my default language was set to xml!?? setting it to sql (sybase) works great, any file I open defaults to sql highlighting and is runnable.

Thanks Daniel