Toad World® Forums

Result - Compare To - criticall


#1

Hi,
I ran 2 queries. In both cases result was not all fetched [only first 500].
On first query I chose Compare with second result. I was asked if I want to read all rows to have complete result set. I agreed.
But only first record set was all fetched. Second result set was sent to compare tool incomplete.

Butter


#2

Please check if you have “Number of rows to initially fetch in data tab” applied to editor. It can be found in Tools | Options | database | General page. Please uncheck it to always fetch all rows.


#3

Kiki,
I know how to avoid this issue/ situation ;). What I’m intend to say is that application’s behavior shall be changed - full fetch has to be performed automatically for both recordsets, not against first only.

Butter


#4

Thanks. I created CR107734 to track the issue.