Toad World® Forums

reverse ddl bug


#1

Start with preferences
extract ddl
table / view specific
Include primary key in table definition.

If you select include primary key in table def. and referse a partitiond table, nav does not keep the local indexes, it changes the index to a global index.

This is a very bad thing if your maintaining a data wharehouse with sql nav.

If your index is local, it should still be local after nav referses the ddl.


#2

Hi Henry,

I tested this but I couldn’t see any difference when I ticked the preference “Include primary key in table definiation” on or off. I could see the LOCAL option in the DDL. I attached the screen shot here. Do I miss anything? Or could you send me the DDL of you table and index?

Thanks,
Vincent
LOCAL_IDX.jpeg