Toad World® Forums

Reverse Engineering Wizard - JScript runtime error


#1

I’ve tried to reverse engineer from a MS Sql 2005 database and received the following error in the last step of the wizard:

Source: Microsoft JScript runtiem error
Script: RE MS SQL Server 2005
Description: ‘GetFieldValue(…)’ is null or not an object
Row: 688
Column: 9

CallStack:

Tried various selections on the items to reverse engineer from the database, but doesn’t seem to matter.

Darin

error.jpeg

wizard.jpeg


#2

More information…

When I click Execute again, I receive a different error…

Source: CS3 - Internal error
Script: RE MS SQL Server 2005
Description: Operation is not allowed when the object is open
Row: 146
Column: 3

Callstack:

Couple more attachments as well…

This just keeps appearing if you click Execute

DArin
messages.jpeg


#3

More information…

When I click Execute again, I receive a different error…

Source: CS3 - Internal error
Script: RE MS SQL Server 2005
Description: Operation is not allowed when the object is open
Row: 146
Column: 3

Callstack:

Couple more attachments as well…

This just keeps appearing if you click Execute

DArin
error2.jpeg


#4

Hello Darin,

We’d like to ask you for following information:

  1. What connection did you use? - ODBC or ADO?

  2. If ADO, could you please write us what provided did you select?

There seems to be a problem during loading of information on Identity column.

Thanks for the details.

Regards,

Vladka + Mario


#5

I used the ADO connection
and the SQL Native Client

I looked through the script and it seems to fail when it tries to get the seed. Could find the actual query string that it tries to pass, but could be an issue with the query itself.


#6

Just a quick update: We’re dealing with this issue and sent Darin a private message. More information is required.
Waiting for the reply.

Vladka


#7

Any resolution? - I get the same behavior with current BETA download.

I have tried a connection string using Provider=SQLNCLI.1
and Provider=SQLOLEDB.1

Also I only get “Connection via ADO” in the dropdown for connection type…

I also noticed this posted message thread did not show up on quest.com forums when I searched for “jscript” only found this one using Google hits…

Bill


#8

When I first searched the forum for “jscript” this thread/posting did not appear (Even with options of All Groups, all posting no matter how old). Oh well, finds it now. Perhaps the forums had/have an indexing issue…


#9

Hello,

We’ve made some changes in the package for RE MS SQL 2005 and now are testing it. Thanks for your patience.

Also I only get “Connection via ADO” in the dropdown for connection type…

Yes, in the latest Beta, only ADO connection is available. ODBC has been removed as we’re still working on it. Thanks.

Regards,

Vladka