Toad World® Forums

Right-Click Refresh table cleared the list of databases in Object Explorer


#1

5.0.0.133 build:

After creating a new table via a SQL Script I right clicked on the “Tables”
object of the database I was working on and chose the refresh option.

Now in object explorer, it no longer lists any databases under the databases
node:

if I close the object explorer (little x in top right) and then re-open it from
the View menu, I get this error:

System.NullReferenceException

Object reference not set to an instance of an object.

Stack Trace:

at Quest.Toad.SqlServer.ActionHandler.DTC.DTCInvoke…ctor()

at Quest.Toad.SqlServer.Trl.DTC.DTCListTrl.get_ImageIndex()

at Quest.Toad.DatabaseBrowser.ObjectPaletteControl.SetNodeImage(TreeListNode
node, ITrl trl)

at Quest.Toad.DatabaseBrowser.ObjectPaletteControl.RebuildUI()

at
Quest.Toad.DatabaseBrowser.ObjectPaletteControl.ObjectPaletteControl_Load(Object
sender, EventArgs e)

at System.EventHandler.Invoke(Object sender, EventArgs e)

at System.Windows.Forms.UserControl.OnLoad(EventArgs e)

at DevExpress.XtraEditors.XtraUserControl.OnLoad(EventArgs e)

at System.Windows.Forms.UserControl.OnCreateControl()

at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)

at System.Windows.Forms.Control.CreateControl()

at System.Windows.Forms.Control.ControlCollection.Add(Control value)

at Quest.Toad.Gui.MainForm.GetToolWin(ToolWindow dockControl)

at Quest.Toad.Gui.MainForm.toolWindow_Paint(Object sender, PaintEventArgs e)

at System.Windows.Forms.Control.OnPaint(PaintEventArgs e)

at System.Windows.Forms.Control.PaintWithErrorHandling(PaintEventArgs e, Int16
layer, Boolean disposeEventArgs)

at System.Windows.Forms.Control.WmPaint(Message& m)

at System.Windows.Forms.Control.WndProc(Message& m)

at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)

at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)

at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr
wparam, IntPtr lparam)

And if I try to expand the databases node, I cannot. (Clicking the plus sign
beside databases doesn’t show any).

To fix the problem I had to disconnect from the server completely then
re-connect.

Darren

image004.png