Toad World® Forums

Running a procedure in Debug


#1

In 5.5 we get this:

15:46:36 Initialize debug session failed (DEBUG ANY PROCEDURE and DEBUG CONNECT SESSION privileges needed): ORA-01031: insufficient privileges
15:46:36 ORA-06512: at “SYS.PBSDE”, line 78
15:46:36 ORA-06512: at “SYS.DBMS_DEBUG”, line 224
15:46:36 ORA-06512: at line 2

In 6.0 we get:
3:48:51 PM Operation aborted

There was no indication that there was a permissions problem.

I hope you don’t have too many questions, it is not me that found this, and I am not familiar with this at all…


#2

Hi Dale,

Does he want 6.0 to give more details on what went wrong?

Gwen


#3

Yes, he kept trying 6 and kept getting the operation aborted message. He tried a number of things and nothing worked, finally he brought up 5.x and got the Insufficient priveleges message. After the priveleges were granted I do not believe he tried 6 again, I think he stayed in 5.x. But without a message telling him why it aborted he had no idea what was wrong, from his stand point 6 just didn’t work.


#4

I think that kind of helpful messages explaining what was missing is a feature that should be in 6.* (it also happens with java classes…telling the script for the permissions that are needed


#5

Hey guys,

You have a valid point there. SQL Navigator should definitely let the user know what’s wrong so he can fix it. I will raise a request to improve this.

Gwen