Toad World® Forums

Save Parameters from Execute wizard does not save default and expressions


#1

Hi!

Call the execute wizard.
Set an expression or an default parameter.
Save your parameters.
If you look at the file or load the file to execute wizard, you see that you loose that information.

Regards


#2

I do not have that problem


#3

You must close and reopen the execute wizard before loading the arg file. In the same wizard session the parameters seems to be cached, as long they are not overwrited from loaded file (which does not contain the setting).
wizard_after_load.jpeg


#4

You must close and reopen the execute wizard before loading the arg file. In the same wizard session the parameters seems to be cached, as long they are not overwrited from loaded file (which does not contain the setting).
wizard_save.jpeg


#5

You must close and reopen the execute wizard before loading the arg file. In the same wizard session the parameters seems to be cached, as long they are not overwrited from loaded file (which does not contain the setting).
save_file.jpeg


#6

Thanks Torsten

Problems I got;
1- when saving with all parameters at null it doesn’t save (creates file) if the file doesn’t exists ( the same applies to Default values or mix between nulls and defaults)
2- the save file doesn’t make any distinction if the parameter was using default or null and when loading leaves the value that was there
(for instance if your procedure has 2 parameters and you have value1 and value2 there when loading and only the first parameter has a value3 in the file you will get value3+value2 after loading and not value3+null (or default))

Regards


#7

Thanks for reporting these problems.
CR is raised, will be fixed them in the future build.

Regards
Lyla


#8

Fixed in 6.4.0.1930.