Toad World® Forums

Scheduling failing


#1

We have a .tas script which exports data from TDP local storage into several Access Databases. It runs succesfully if we launch manually. We have tried to schedule it to run once but each time we have tried it it fails.

Test 1 - we tried scheduling it within TDP. The task failed.

Test 2 - we tried running it on the command line (it failed because there are spaces in a folder name in the arguments). We moved the tas file into a folder with no spaces and it ran successfully from the command line.

Test 3 - we tried scheduling it from within TDP - it launched Toad but then quit a few seconds later - no data was exported.

We are using an admin level id and password

Anyone else had this problem?


#2

To Spligosh:

Welcome back to Toad World! We are sorry to hear you are having issues with our scheduler. I understand that Windows Scheduler is reporting that automation scripts fail when scheduled through TDP (If this is not the case, please attach a screenshot of the issue to clarify). I anticipate that the Window’s Scheduler last run result and the Automation Log File.

We humbly ask to repeat each of the test scenarios requested, note the time the scenario was executed, and then retrieve the two items mentioned earlier.

To retrieve the Window’s Scehduler last run result

  1. Go to “Start” -> “Task Scheduler”

  2. On the left hand pane of the Task Scheduler, select “Task Scheduler Library”

  3. In the middle, go thru the list and find the name of your scheduled task. It should match the name of the script.

  4. In the row with the scheduled task, scroll to the right (If applicable) to see the “Last Run Time” & the “Last Run Result.”


    To retrieve the Automation Log File

  5. Navigate to the Application Directory Automation folder (ie: C:\Users\currentusername\AppData\Roaming\Quest Software\Toad Data Point 3.5\Automation)

  6. Look for the log file that matches the name of your automation script / .tas file.


    Both of these may offer clues to address the situation. Feel free to post the screenshots/log files here or email them to Joshua.Liong@quest.com if you would like us to take a look at it too!

I hope this was of assistance,

-Joshua Liong


#3

Thanks Joshua once again :slight_smile:

It looks like it may be a permissions issue - I don’t think we have batch run permissions. We are awaiting an ID and correct permissions to enable us to do this. I’ll update once I’ve confirmed whether this works or not.


#4

Well it still didn’t work but we have managed to get to the bottom of the problem and I think it is probably worth explaining the scenario just incase anyone else has the same issue.

  1. The copy of Toad Data Point I use sits on a virtual server. I have admin rights with my normal user ID but not batch rights. The local storage for this server is on a separate partitioned D drive. I could schedule our automation under my normal ID and it would run as long as I was logged in.
  2. I requested a generic ID from our security team with batch rights
  3. When I tried to use the new generic user ID the schedule ran successfully but the automation did not?
  4. After further investigation the problem was eventually found in the fact that the automation we were trying to run was to export data from local storage to MS Access databases. As the location of the Local Storage database is stored under the original user’s profile the new ID was looking in the default C drive location and not on our separate D Drive.
  5. Once I had logged on as the generic ID and set the location of the local storage to the D Drive (and then connected to the local storage - doesn’t hold the path if you don’t) - the next time I tried to use the generic ID in automation it ran successfully even when I was not logged in.
    So - the lesson (if you haven’t fallen asleep by now) is that if you use a separate ID to run your batch schedules make sure that it can see all your connection data (including your local storage).before you attempt to run any automation schedules.

Thanks to everyone who helped me get to this understanding.


#5

Arghhhh! Schedule kicked off at quarter past midnight today. Failed becuase it tried to find the first automation in the default C drive location!!!

Is there any way to tell TDP to use the original location for the automation (that is on my D Drive). Where is this setting stored?