Toad World® Forums

Schema creation corrupts Object explorer (one time occurence)


#1

I was running the following script and it did something weird like change the
creation date and modify date to DSTY and FG, which has no understanding. See
Graphic below. A refresh did not resolve the problem. This may be a bug because
I had to exit Toad-SS-B and restart it… I could not reproduce this error.

IF EXISTS (SELECT [schema_id] FROM [sys].[schemas] WHERE [name] = N’sprockets’)
BEGIN
PRINT N’Schema sprockets exists.’;
END
ELSE
BEGIN
EXECUTE (‘CREATE SCHEMA [sprockets] AUTHORIZATION [dbo];’);
PRINT N’Schema sprockets created.’;
END

See webpage http://msdn.microsoft.com/en-us/library/ms189462.aspx

Hank Freeman

Senior Systems, Database/Data Warehouse Architect

hfreeman@msn.com

678-414-0090 my cell Primary

image001.gif

image002.jpeg

image003.png


#2

Hello Hank,

This bug does not related with execution script that you’ve typed below.
Seems there were some problems with refresh and read the data. Unfortunately, we
could not reproduce this issue on our side.

Thank you for your report, we’ll pay attention on this bug.

Thanks,

Anastasia
image002.jpeg


#3

Hello Hank,

This bug does not related with execution script that you’ve typed below.
Seems there were some problems with refresh and read the data. Unfortunately, we
could not reproduce this issue on our side.

Thank you for your report, we’ll pay attention on this bug.

Thanks,

Anastasia
image003.png


#4

Hello Hank,

This bug does not related with execution script that you’ve typed below.
Seems there were some problems with refresh and read the data. Unfortunately, we
could not reproduce this issue on our side.

Thank you for your report, we’ll pay attention on this bug.

Thanks,

Anastasia
image001.gif


#5

Hello Hank,

This bug does not related with execution script that you’ve typed below.
Seems there were some problems with refresh and read the data. Unfortunately, we
could not reproduce this issue on our side.

Thank you for your report, we’ll pay attention on this bug.

Thanks,

Anastasia
image001.jpeg


#6

Hello Hank,

This bug does not related with execution script that you’ve typed below.
Seems there were some problems with refresh and read the data. Unfortunately, we
could not reproduce this issue on our side.

Thank you for your report, we’ll pay attention on this bug.

Thanks,

Anastasia
image001.jpeg


#7

Anastasia thanks for the email.

It may be related to Toad-SS out of resources, because I was using BULK InSERT
and the sytem was allocating 3.7 gb of memory to SQL Server. So this may be an
isolated occurrence, for which I just wanted to report in case others get into
the same scenario.

Hank Freeman

Senior Systems, Database/Data Warehouse Architect

hfreeman@msn.com

678-414-0090 my cell Primary
image002.jpeg


#8

Anastasia thanks for the email.

It may be related to Toad-SS out of resources, because I was using BULK InSERT
and the sytem was allocating 3.7 gb of memory to SQL Server. So this may be an
isolated occurrence, for which I just wanted to report in case others get into
the same scenario.

Hank Freeman

Senior Systems, Database/Data Warehouse Architect

hfreeman@msn.com

678-414-0090 my cell Primary
image003.png


#9

Anastasia thanks for the email.

It may be related to Toad-SS out of resources, because I was using BULK InSERT
and the sytem was allocating 3.7 gb of memory to SQL Server. So this may be an
isolated occurrence, for which I just wanted to report in case others get into
the same scenario.

Hank Freeman

Senior Systems, Database/Data Warehouse Architect

hfreeman@msn.com

678-414-0090 my cell Primary
image001.gif