Toad World® Forums

Session Manager: GetSession - Index out of bounds


#1

I have the preference selected that closes the session when the last window is closed. I am now getting a “Session Manager: GetSession - Index out of bounds” in the output window whenever I close the last window of any session. It doesn’t seem to affect anything, but is somewhat disconcerting.

Occurs in 6.3 Beta 1789, but does not occur in 6.2.1 using same connections.


#2

It may be unrelated, but after a while, I found I could no longer open any other sessions nor shut the program down without getting a Index out of bounds error. I forced it closed via task manager and ran it again. It loaded fine and can open sessions fine, but each time I close a session I get the same error.


#3

Hi Mark,

We can duplicate this error, a CR have created for it. But we can create new session after this happen.

Thanks for reporting this problem.
Jeff


#4

Yeah, I can normally also. I’m not certain why it changed all of a sudden. I suddenly couldn’t create a new session nor exit the program. I could only get that error. I’ve been unable to repeat that part of it so far.

Seems to be solved in 1796 build. Nice turn-around time!