Toad World® Forums

Set not Bolded


#1

Not sure if this is intentional, but in an update statement the set is not blue like the other “reserve” words…


#2

Hi Dale,

It should be highlighted like other RESERVED word.

We all tried it here and could not reproduce the problem.

All the key words for highlight are specified in the 2 text files located in the application installation folder. SET should be in the PLSQL_reswords.txt. Could you please check it out to the file contents on your environment:
PLSQL_reswords.txt
PLSQL_datatypes.txt

Do you only have this issue with the Update statement?

Thanks,
Bruce


#3

See Attached…

1 additional note, you asked if anything else was not highlighted correctly… No, everything else seems normal (as I would expect).

Message was edited by: Lozier
setgreen.gif


#4

Hi Dale,

So far, I couln’t reproduce. SET appears green (as a SQL*Plus keyword) in the Classic color scheme. Which scheme are you using?

Thanks,
Roman


#5

If by Classic Schema you mean Window’s Classic Schema, no I was using xp schema. I switced to classic schema and set did not turn blue. If no one else is experiencing this problem and you can not recreate it, let’s just call it a “fluke” on my PC. It’s not terribly important.


#6

No, I meant the syntax highlighting scheme that is selected in Code Editor preferences.


#7

Sorry, I can not check that at this time, my Navigator has expired…


#8

Attached is what I think you are asking for. If it is any consolation, this only seems to happen in the 10G database. The 8.1.7.4 the set is highlited correctly, also in 9.2.0.7 it is highlighted correctly…
601686-0001.jpeg


#9

Hi Dale,
I can reproduce this issue in my machine and it always appears green regardless of the database I use. Deleting and adding it to the PLSQL_reswords doesn’t make any difference. Strangely, it only happens for this particular word. We will have a look on it but like you said it is a low priority.