Toad World® Forums

setting the order of attributes (columns) in an entity / table


I’m not sure what I’m doing wrong or if this is a bug (or something that was overlooked in the program).

Situation: In an “entity properties” dialogue under the “attributes” tab, I clicked on the “Name” header and the dialogue sorted the attributes by name (reasonable so for).

The problem: I can’t figure out how to get the dialogue to show the columns in the order that I want them to actually appear in the table. The only kind of attribute sorts I can do now is to click on the dialogue columns (‘Name’, ‘Caption’, ‘Data Type’). Even if I click on one of the attributes for my table that I defined, the green ‘up’ and ‘down’ triangles/arrows at the bottom to the right of the ‘add attribute’ box are greyed out, and I can’t move my attributes up or down. And I can’t find a way to get the dialogue to show the attribute order I originally designated.

More, this is the case for all entities now, even new ones.

In my worst German (for fun) Was ist los? Am I losing it? Tell me please that I just don’t know where to click the right thing to give me my column orders back, and where to find it.

Message was edited by: BillR


Hello Bill,

Please click the header of the first column (the column on the left of the Key column) to enable the green arrows and then reorder the attributes.

Please find attached a text on this issue taken from the documentation (ready for v. 3.1)

If you have any questions, please write me back. Thanks.


Attributes_Order_Enable_Arrows.pdf (106 KB)


Thanks Vladka. That worked. But this current functionality for resetting the column order is pretty obtuse. I think it would be good if you found a more obvious/intuitive way to reset the column order. Thanks again.


Thanks, Bill. We will consider it once again trying to find another, more intuitive way.
CR # 46 434.

Have a nice day.



Just a quick update:
Flash movie on ordering attributes:



thanks :slight_smile: