Toad World® Forums

Sharepoint online in Toad Data Point 5.0 beta


#1

I posted a question a while back about connecting to SharePoint online (https://community.toadworld.com/products/toad-data-point/f/36/t/34786) and it sounded like this would be in the current beta, but I am trying to connect and still cannot. Is this connection available?


#2

It is not in the current Beta but is being worked on now.


#3

Support for SharePoint online is available in the latest Beta.

Please download and give it a try [H]
community.toadworld.com/…/


#4

Is it possible to get more information regarding SharePoint online connections in the beta build?


#5

You can now connect to SharePoint online. Define a new connection and select the Online check box.


#6

I can’t find the beta page to download. Please provide instructions.


#7

what url should be used, instance or site level? should the vti bin extension be added to the url?


#8

here is Beta download page. Go to top of post. Toad Data Point 5.0 Beta Program


#9

You still use the same _vti_bin/listdata.svc extension


#10

Tried a number of things but still cannot connect to sharepoint online. Is there anything that I should be trying? Are there any specific sharepoint settings that need to be considered?

Resulting error message
2018-09-18_8-18-09


#11

Let me have our QA check on this. They will be in later today.


#12

Really appreciate it!


#13

Please test again with replace the HUB.DLL,then get bundle file for me. Thanks
The site cannot upload zip file.
I cannot find out your email address, so please contact with me Zhiming.Lin@quest.com to get the new file HUB.DLL

Test SharePoint Online Steps.pdf (229.1 KB)


#14

Just emailed you thanks!


#15

Add results here:

  1. Toad Data Point connects to login.microsoftonline.com 443 for share point online connection.
  2. In this case, 443 port was blocked by the server firewall.
  3. After update the firewall setting, the issue was solved.

If user meets issues when connect to sharepoint online in Toad Data Point, user can check the below setting first:
run telnet login.microsoftonline.com 443 in your windows command
If it can connect to it successfully, the command window would switch to telnet mode
If CANNOT telnet to login.microsoftonline.com 443, maybe need to check with the firewall setting and IT admin.


#16

Hi, I'm getting the following error message:
image

Any ideas as to why that's happening?