Toad World® Forums

slow Expanding list of tables...??


#1

Hi i noticed strange situation, when i use default date format as specified , for example YYYYMMDD, expanding list of
tables is normal, below 1 sec. When I use default date format - set to , list of tables expands
extremly slow!!
When you set specified date format sqlnav executes alter session set default_date_format =… , it looks like, fast expanding depends from executing this command…

Check this.

I was connecting into 10.2.0.2 database (HP-UX and WIdows)

Regards Piter


#2

Hi Piter,

Thanks for your feedback. I was unable to reproduce your situation where the the table node expands extremely slowly so I would like to clarify some details with you:

  1. How many tables under the Tables node ? -> The 10gR2 DB I used had 733 tables

  2. When you say “extremely slow”, roughly how many seconds (hopefully not minutes !!!) are you talking about ? -> For me, I clocked my expansion time at approx 0.7 sec to 1.5 sec or so.

  3. How does your use case compare to my following sequence of steps:

  4. Open NAV but don’t log in.

  5. Go to Preference -> User Interface and set “Date Displayed Format” to YYY-MM-DD or DD/MM/RR (pick one)

  6. Go to Preference -> Session and set “Default date format” to YYYY-MM-DD.

  7. Click OK

  8. Log on and expand Tables node

  9. Close session and Repeat Step 3 except now “Default date format” is set to “”

  10. Log on and expand Tables node

For me, there wasn’t a huge time difference between Step 5 and Step 7. Is your sequence of steps familar to mine ? If not, could you please describle how it differs , thanks.

regards,

Bernard


#3

Hi Bernard
I did those tests. So my settings were:
1 test :
Displayed format YYYY-MM-DD
Session format YYYYMMDD
expanding time - below second
attachement:user_interface.jpg,session.jpg,navlog0000.log

2 test:
Displayed format YYYY-MM-DD

Session format

time: about 5 mnutes
attachement:user_interface.jpg,session_slow,navlog0000_slow.log

3 test

Dispayed format YYYY-MM-DD (default for polish windows settings)
Session format YYYY-MM-DD
time: about 5 minutes

It looks like format YYYY-MM-DD is going slower than others!

Regards Piter
navlog0000.zip (199 KB)


#4

Hi Piter,

Thanks for the feedback. Andrew and myself attempted again to reproduce your issue using Polish regional settings, and with your preferences as indicated in your screenshots. Unfortunately, we found that regardless of which date format we picked, we could not reproduce the massive lag that you experienced. So, while we will continue our investigations,
could you please:

  1. Let us know how many tables are under the Tables nodes that you’re expanding ? Are we talking about hundreds or thousands (or more) ?

  2. In your session preference for “Default Date Format”, could you manually type in YYYY/MM/DD and apply the change ? We would like to see if using a different separator (using “/” instead of “-”) will improve the performance for you.

Thanks !

regards,

Bernard


#5

Hi!
Of course using “/” speeds up expanding. In my schema are about 200 tables. But what I find, this situation occurs only on HP-UX database. I tested on two 10.2.0.2 (HP-UX 11.23) and two 10.2.0.2 (Windows 2003 Serv and XP SP2), I will test this using my customer’s databases, and will try why does it happends! It looks like this could be Ora Database problem.
Let you know what i find.

Regards Piter


#6

Hi Piter,

Hmm…that’s interesting. Thanks for taking the time to test this.

regards,

Bernard


#7

it looks like this is the database problem :frowning:


#8

Hi Piter,

Thanks for the update.

regards,

Bernard