Toad World® Forums

Some results from testing Toad for SAP 3.0 Beta

Hallo,

during the evaluation of Toad for Sybase resp. SAP (versions 2.x and 3.0), I found the following issues:

Access to system tables

Since Version 3.0 Toad seems to require access to some system tables, which are not accessible to “normal” users in our setup:

  • Executing “alter table” from the “Object Explorer” fails, because it seems to require access to the “dbccdb” system database.
  • Toad seems to require access to the “sybmgmtdb” during initial connection:
    • When opening the first connection from the Connection Manager, it seems that Toad tries to query sybmgmtdb and receives an error form the server, that the connecting user is not valid for this database.
    • After closing the error message, one of the following happens:
      • Everything works fine
      • Everything works fine, but the Object Explorer is empty. After refreshing, e.g. pressing F5, everything is ok. In some cases the Filter-Inputbox is missing after refreshing.
      • An error occurs (if needed, I can provide message and stack trace)
    • Opening or reopening a second connection to the same or a different server works without problems, as long as one other connection is open.
      Both system database are not (and will not be) accessible to “normal” users in our setup. In versions before 3.0, these issues did not exist. Therefore, I am wondering, if this is really needed or could, for example, be controlled by a configuration switch. Is there any posibility to prevent access to these databases in the current version of Toad?

Handling numeric and decimal columns in grids

  • Display, sorting and filtering of columns of type numeric or decimal does not work correctly in grids.
  • The issue exists in all tested versions of Toad. All tests have been performed with German localization settings.
  • Sorting a grid column with values from a numeric or decimal column is somewhat arbitrary. Depending of the pre-sorting from the query (order by clause) the grid sorting results in different orders.
  • Filtering does not work correctly in some cases:
    • “Equal” and “not equals”: result is correct.
    • “less/greater than”, “less/greater than or equal to”: result is correct, iff the comparison value is negative. If the value is positive, the result contains positive and negative values.
    • “less” and “greater” seem to be mismatched.
    • Example:
      • Source: -0.3, -0.2, -0.1, 0.0, 0.1, 0.2, 0.3
      • Filter “less than 0.1”: -0.3, -0.2, 0.2, 0.3
      • Filter “greater than 0.2”: -0.1, 0.0, 0.1
        Handling results from print statements

This is not actually an error, but I would suggest to make it configurable. Furthermore, the behavior is not consistent.

  • The results of print statements are displayed as a separate result set for each single print statement. We often use print statements to control the status of loops over cursors. This can result in several thousand result sets displayed in Toad, which is very confusing.
  • The results of print statements of consecutive runs of a script in the same editor are displayed in the same “Result Sets” tab, making it difficult to distinguish the output of the different executions.
  • The display of results of print statements in the “Messages” tab is incomplete. Sometimes they are displayed completely, sometimes partially and sometimes not at all. Independent from this display, the display as result sets is always complete.
  • Toad ignores the setting of “flushmessages”. It always postpones the output of print Statement until the script has finished.
    SQL-Debugger

Nice tool. :slight_smile: Just two minor question:

  • Hitting F8 (“Step over”) resumes execution to the end of the script or the next breakpoint. Shouldn’t it just execute the next statement?
  • Is it possible to step into a procedure executed inside the procedure the debugger was started on (e.g. stepping into procB which is “exec procB” inside procA)? I thought that F7 (“Step Into”) should do this, but it actually executed the whole procedure in one step.
    If needed, I can provide additional Information like scripts and error messages.

Final remark: All tests have been performed on Sybase ASE 15.7 and Sybase ASE 12.5 using Toad for SAP Beta Build 3.0.0.306.

I hope you could help with these issues, because we need to make a tool decision and the mentioned issues are critical for us.

Best regards,

Dirk

Hello DirkJ,

Thank you for taking the time to write up such an extensive post. We are currently reviewing the items and we will respond with a summary soon.

Thanks again!

Hello DirkJ,

Please see our progress in the chart below:

Access to system tables
TSY-1140
Fixed (Any config switch for preventing access to the databases is not needed - it was a bug).
Handing numeric and decimals column in data grid
TSY-1144, TSY-1145
Fixed.
Print statements - Confusing result sets
N/A
Could you explain in more details with some screenshots what you mean?
Print statements - Incomplete results
N/A
We would need to have more info to recreate this.
Print statements - Flushmessages
TSY-1162
We are not sure if we’re able to fix it for this release but please stay tuned.
SQL Debugger - Step Over
TSY-1159
Fixed.
SQL Debugger - Step Into
TSY-293
We know about this for some time. This issue is connected to the client and it probably will have to be deferred to the next release.
Thank you very much for your comments and we hope you will be happy with the changes after our next Beta build!

Regards,

Hello Daniel,

sounds very good. Are these fixes already included in the 3.0.0.666 version?

Regarding the print statements, please have a look at the attached PDF file. I created a detailed description including some screen shots. I hope this will clarify it a bit more.

Regards,

Dirk
Toad_Beta_print_statement.pdf (160 KB)

Hi DirkJ,

No, unfortunately not - The last beta was from the 10th March.

They are going to be in the next Beta, which is most probably going to be uploaded the next Monday - but please check our beta release notes Resolved section to be sure.

Thanks for the PDF with print information, we’ll see what we can do.

Hi,

I checked the new Beta (3.0.0.723). There are still two problems:

TSY-1140:

Alter table works , but I still get the same error when opening the first connection.

TSY-1144/1145:

Seems ok. But there is still one (new?) issue: Set a custom filter on a numeric column, e.g. “Equals 1.0”. The filtered list will be correct. Open “Custom AutoFilter” again on the same column. Type in a value (the same or a new one). Do not touch the type of comparison! Click “OK”. Now the grid is empty, regardless of what value you typed. You have to remove an existing filter before changing it. Again, this applies only to numeric and decimal columns other types work correctly.

Regards,

Dirk

Hi DirkJ,

we cannot reproduce TSY-1140 as you were describing it but we thought it was fixed as it seemed to be connected to other issue. Can you send us the detail of the exception you are getting?

For TSY-1144/1145: devs have already adressed it and currently it is in testing.

Thank you for your feedback!

Hello Daniel,

I prepared a PDF with (based on version 3.0.0.723) some images that show the errors. Maybe this will help you to reproduce the error.

Regards,

Dirk
Toad_Error_on_Connection.pdf (229 KB)

Hi DirkJ,

the bug you are writing about is fixed in the current beta - 3.0.0.749.

Thank you for your comments,

Hello Daniel,

now it works. Thanks very much.

Are there any news about the issue with print statements? Mainly the two that do not have a ticket number in the reply from March 13 are of interest.

Btw.:

The debugger does not like “,” (comma) in start parameters, even if it is a varchar.

To test: Run the debugger on a procedure with a varchar Parameter. Type “Hello, World” in the value field. This leads to something like ‘The value must not contain the character “,”.’ (at least on my test system). Is this the intended behavior?

Regards,

Dirk

Hi DirkJ,

it is still very much undecided if/when we are going to address the print stuff. Right now we do not have much time before our 3.0 release is finished - currently we have higher priority issues and as you stated “This is not actually an error”. We will discuss it with our product manager and development and if you have some time you might post it in the Idea pond section. It would help us understand the benefits of such features a lot and we could see if other users are also interested in this feature.

The debugger related fix concerning “,” was a quick one and will be fixed in the next beta - TSY-1258 - thanks for noting.

Regards,