Toad World® Forums

SQL Nav 7.2 Beta : quick test

Hi

Just installed v7.2 beta. On my PC I have 6.7 and 7.1.

  • No parameters were taken over to 7.2, I had to set all preferences, all my connections to the databases, and all formatting options, and to type in our key. In the former versions, I did not need to do this.

  • Code between /* and */ or after – is no more in italic.

  • I copied the fmtOption.opt file into the new directory and pointed the formatter to this one. Formatting works. Tired to change a detail, and got this message :

Message is about the xml file, but i use the .opt file. In the directory, both have a new date of update.

Regards

Martin

Hi Martin,

Thanks for you feedback.

–Settings cannot be automatically migrated from 6.7 or 7.1 to 7.2: this is a known issue. We have story SQLNAV-1726 for it and it
will be fixed in the next beta. The workaround is:

  1. open SQL Navigator 7.1;

  2. open Tools | Profile Manager from 7.1;

  3. backup user profile for SQL Navigator 7.1.0 or 6.7.0;

  4. open SQL Navigator 7.2 beta;

  5. open Profile Manager from 7.2 and select the 7.1/6.7 backup file to restore into SQL Navigator 7.2.0

  6. now start SQL Navigator 7.2 normally you should have all settings in place.

–I hope the migration of settings above solves the formatter options error. If it doesn’t, please follow steps below:

  1. remove any FmtOptions.opt/FmtOptions.xml/FmtOptions.opt.xml/FmtOptions.xml.opt files from %APPDATA%\Dell\SQL Navigator 7.2.0 Beta
    folder;

  2. copy the FmtOptions.opt file from %APPDATA%\Dell\SQL Navigator 7.1.0\ folder to the 7.2.0 folder above;

  3. open Formatter Options from 7.2 beta;

  4. user Open dialog to load the FmtOptions.opt into formatter options;

  5. now try to update any options and save – if error still occurs, please let me know.

Thanks,

Vincent

Hi Vincent

I’ve already made all parametrization manually :wink: I’ll try this by next version.

Save of the formatting file works now fine : seems the error massage only displayed the first time.

Regards

Martin

Good to know you made them work alreadyJ .
Thanks for the update.