Toad World® Forums

SQL Navigator 6.6 Keeps Freezing

Version 6.6 keeps freezing on me while typing at random moments. I’ve tried killing the session with no avail thinking it’s the background thread that’s stuck, but the only way is to force kill the program from window, I’ve also tried leaving the program running until either responds/crashes for a couple of hours and nothing. Is there any log or something that can be examined since I haven’t been able to reproduce the error since it appears to be random.

Regards

Hi Rony,

We haven’t set up any logging routine in SQL Navigator, but you can start Quest SQL Tracker to momitor the SQLs that SQL Navigator is running. Let me know if you need any help to use SQL Tracker.

Thanks,
Vincent

No, I don’t think it’s a matter of a running SQL, since I’ve monitored the program through Toad and when it hangs the attached db session remains idle. This behavior actually started since beta 6.60.2220, previous 6.6 betas I was getting stable performance. I’ve even had a case when I just opened the program, the Oracle Logon window came up (I don’t save the previous session so it should be fresh start) and it immidiatley froze! The freezes mostly involve the SQL Editor, just clicking on the screen causes a freeze, or sometimes while the window is in the background (idle i must add) it just freezes out of the blue, hence why I haven’t actually been able to reproduce the conditions for the error since it appears (to me) completely random. So my doubt is, is there a program log or something that could be examined?

Hi Rony,

We don’t have program log to trace what SQL Nav is doing. May I ask whether all the occasions that SQL Nav froze involved Oracle connection? In other words, did they happen when SQL Nav connected to Oracle? If so, the log of SQL Tracker can show us what SQL has been run and what the last SQL was. That would help our developers roughly locate the area that may cause error.

Thanks,
Vincent

I’m experiencing the same kind of freezeing. It seems random and dosen’t just happen when running queries so it´s not a matter of a stuck query. I’ve also tried leaving the program running for 12 hours. I’m running version 6.6.0.2293 on Windows 7 64bit. I have not noticed this kind of freezeing in previous version but then I was running Windows XP.

Hope there’s a patch coming to fix this or I will have to downgrade again.

Best regards,
Andri

I don’t know if this helps, but I have the same problem. I did not report it because I could not find any rhyme or reason. One thing that does seem common is when I change the output area (resize). Either by dragging or using the . I can not recreate this at will, so I have not reported it.

The paste of the button didn’t seem to work. Here it is attached.
resize.bmp

Hence why I couldn’t follow up, I never actually found a reason for it, and it seams totally random. A coworker also installed version 6.6 and is experiencing the same freezing. In our case, we are running windows 6.1.7600 on 32 bit. Personally I downgraded to 6.5 because of the issue.

Hi All,

Many thanks again to all for your notes and feedbacks. We have tried but could not reproduce the issue yet. We could not neither determine what or which area might cause the hang issue. We will keep trying and will keep you all posted when we could make any progress.

Thanks and regards,
Bruce

Ok, here are the steps I just took and navigator hung. I hit the expand output button. Ran a sql, hit the button again (the window didn’t move), grabbed the resize double line. Drug the window down. Unpinned the navigator then hit [F9] button and it froze. Now I have had navigator up all morning 5+ hours, so there were lots of other things being done, but once I did these steps it hung. I am leaning more towards the pinning/unpinning of the navigator window as the cause. Maybe there is some registry entry that got corrupted for the display during the upgrade that you don’t have???

Ok, Now I killed that navigator instance because it never came back. I launched navigator from scratch. The window was still unpinned so without even letting it collapse I pinned it. Ran a very basic sql twice and it has frozen again.

Could be a good theory, I think I’ve had in my current machine navigators since version 6.2. Probably there is an old registry key getting in the way.

Any procedure for completely cleaning the registry?

Hi All,

We could not get the same issue by following steps reported by Dale with the expand button .

The clean the registry and setting, you can remove or rename the following registry and file folders, for version 6.6:

HKEY_CURRENT_USER\Software\Quest Software\SQL Navigator 6.6.0

and

C:\Documents and Settings\YourUserName\Application Data\Quest Software\SQL Navigator 6.6.0

for wind7 C:\Users\YourUserName\AppData\Roaming\Quest Software\SQL Navigator 6.6.0

Thanks,
Bruce

Hi All,

We could reproduce this issue by similar steps.

I figure it out it might be the history source size is big(history page in Toolbox).
When I delete the history sources, all works fine.
So if you meet this issue frequently, Please try to delete the history…and let us know if it could fix your problem or not.

And we will create a CR and try to fix this issues.
Thanks.

Here is the steps I do:

  1. Click the show output button to hide the output window
  2. Make sure DB Explorer is pined.
  3. Run select * from emp
  4. Click the show output button to show the output window
  5. Trying to pined and unpinned output window
  6. If it could not hang, try to pick one of 1~~5 up until you reproduce it.

Regards
Lyla Su

Message was edited by: Lyla

Initial indications are that this is working. I cleared history to 30 days and attempted the pin unpin and it has not frozen and I have run a number of queries.

Thanks…

Ok, deleted registry keys and the appdata folder, reinstaled version 6.6 and will work with it today all day. I’ll post if i have any problems.

Make sure you reduce you history also…

Deleted the registry, didn’t import my profile when upgrading from 6.5 and cleared the history. Not a single crash. Will have to admit a clean install solves it. The question remains then, what in the things I deleted was actually making it crash?

Well, after some testing, the problem of the random crashes returned. I cleared the history again and the program became stable, then once again the history grew and the crashes returned. Apparently when the history grows too large the problem returns. I have yet to try out version 6.7 so I wouldn’t know if it is affected by the same issue.

I have installed 6.7 and have not had any problems as yet, however I may not use mine as intensely as others?