Toad World® Forums

SQL Navigator 7.0 Beta build 2671 (expires 30 Nov 2012) is now available!


#1

Hi Everyone

We are very proud to announce the first 7.0 beta (2671) drop to our community.

You can download this from the following location:
http://sqlnavigator.inside.quest.com/shares/sqlnavigator/sbin/beta/2671/sqlnav_7.0.0.2671-KX_beta.zip

Note:

  • If you have a previous beta version installed, please uninstall it first and then install this beta .
  • You can install this side by side with your current GA version.

New Features and changes compared to previous release:

Full Unicode support for object names and data
Known issue:

  • If you want to log in with Unicode username, password cannot be saved you will need to re-type it each time. Alt you can enter a English password.

Code Completion/ Dot lookup

  • Improved performance by building up list progressively. List will show what it can fast and add new items progressively.
  • Unicode support has been added
    Known issues:
  • Doesn’t display variables when package is open like it did in 6.7

Themes

  • Additional user Interface styles have been added. XP has been selected as default for compatibility.

Incorporation of 6.7 patches

  • History Hang Issue has been resolved
  • Large Font issue with Job Scheduler
  • Sluggish behavior of SQL Navigator when Default Directory in the preferences is set to “slow” path

Find / Replace have been separated, and have different workflow

  • This should resolve the modal window issue experience in 6.x
    Known issues:
  • Not all regular expression work yet as they did in 6.7
  • Unicode is case sensitive always in the search though. It is not consistent with English characters.
  • Backward direction in Find doesn’t work properly.
  • Selected text doesn’t work, it loses the selection

Syntax Highlight

  • This is more like SQL Navigator version 5.5.
    It resolves many of the issues experienced in 6.x with colors clashing.
    Known issue:
  • Some keywords are not highlighted correct color.

Code Editor’s Toolbar can be customizable now.

Current Known Issues:

  • Team Coding
    There are some instability issues. We will continue to improve this.

  • Profile migration
    Not everything is migrated from 6.7 b/c of compatibility issues
    Font may not migrate correctly from 6.x

  • Code Editor
    Size of font doesn’t change if you work with large Font setting

  • Occasional instability issues, AV experienced when SQL Navigator is closed

PL/SQL Formatter:

  • PT 36043171: error when formatting a PL/SQL package with reserved word ‘Model’ has been FIXED.

Please note this is still work in progress, there are some components that are disabled due to a number of issues of some third party compoents, we will fix those issues during the Beta cycles.
Feel free to give feedback on what you like, or don’t like and any serious issues you may find along the way.

Regards
SQL Navigator Team


#2

Yeah, it won’t start:

Access violation at address 00409766 in module ‘sqlnavigator.exe’. Read of address 00000043

And the “Solution” is:
Install an Oracle Client. It is essential to setup an Oracle client before running SQL Navigator. Please refer to SQL Navigator Installation Notes for more information.

That is no solution for me 'cause I already have SQLnav 6.3 & it works fine with my Oracle client 10.1.0.4.2
(Win7 64-bit)


#3

HI

I am sorry to hear you are having trouble starting SQL navigator 7.0 beta.

I have been doing some research and apparently 10g release 1 clients are not supported on windows 7, so I am suprised to hear that SQL Navigator 6.3 runs with it.

The earliest client I managed to install on my windows 7 64 bit box was a 10g release 2 client but this didnt seem to work for me on any Nav version.

I will look into this further to see what the issues are, but for the moment, is possible that you can install an Oracle 11g (32 bit client) release 1 or 2 client. i have these installed on all of my Windows 7 boxes and I dont have any issues.

regards
Lidia


#4

Hi,

i have try to instsall Nav 7.0 into a non default location with Oracle Client 10G in win7 64 bit, it work for me.

Could you pleasure try to install Nav 7.0 into a non default location (for example: C:\Quest Software…) in your win7 64-bit OS? and see if can work for you.

thanks,
michael


#5

Yes, I got familiar with this aspect of installing, when I tried SQLnav 6.3 to get wokring on my machine and it really helped.
Though it didn’t help this time with 7.0.
Maybe I have to remove my 6.3 and then install 7.0?


#6

If you have SQL Navigator installed to a non-default directory already, then I suspect some corruption has occured with profile migration, can we try to do a clean up and see if it helps.

Here are some steps:

  • First clean the registry
    Bring up regedit and delete key:
    HKEY_CURRENT_USER\Software\Quest Software\SQL Navigator 7.0.0 Beta

  • Next delete the SQL Navigator 7.0 beta profile. Location should be something like this:
    C:\Users\UserName\AppData\Roaming\Quest Software\SQL Navigator 7.0.0 beta

Note: If AppData is not visible you may need to change setting to show hidden folders.

  • Finally start SQL Navigator 7.0 beta, HOWEVER Select “CANCEL” when prompt appears to ‘Import user Profile Settings’

  • Once SQL Nav has started, try to connect to a database again. Ensure you have a valid Home/Client selected if you have more than 1 listed.

I “really” hope this helps.

regards
Lidia


#7

Unfortunalently it did’t help :frowning:

Did all things you suggested, but got the same error right after clicking “Cancel” (in the ‘Import user Profile Settings’ dialog).


#8

Hi Martins,

Thanks for getting back to us that you are still having the issues.

We are still trying to identify what causes the issues you reported. We will keep you posted with more updates later.

Thanks and regards,
Bruce


#9

Cant wait to try SQL Navigator 7 Beta! Please tell me, where can I get an apropriate trial authorisation Key?


#10

Hi,

Can you please send me an email @ bruce.duong@quest.com.

I will send you the Trial key to use with the Beta build.

Thanks,
Bruce


#11

Hi. Any progress on this?

The main thing why I need the latest version is the solution of this problem:
http://sqlnavigator.inside.quest.com/message.jspa?messageID=135392

It is THE MOST ANNOYING THING evaaar :slight_smile:


#12

Hi MPAX

We are currently working on this issue at the moment.
It seems to be related to some work we did in 7.0 related to home switching of the oracle client.
As soon as we have a solution i will post another beta and let you know.

regards
Lidia


#13

Hi MPAX,

PT40261209 has been raised for this issue.
we hope to have an update for you soon

regards
Lidia


#14

Hi MPAX

I think I might have some good news for you.

We found someone internally who was havig the same issue as you, so we were able to investigate a little further.

We tracked down the issue was related to SQL Navigtaor beta1 not accepting trial keys.
I was able to test this and verify that was the cause. I managed to get the exact message you reported in your inital post. When I ran beta2 I didnt have this issue.

So if I am correct, you must be running SQL Navigator 6.7 with a Trial key, is that right?

If so, then please go ahead and download beta2, this issue with the licensing should be resolved. Beta1 AV’s when Trial license is already installed or entered on startup, beta2 has been fixed, this should no longer occur.

If you dont believe you are using a trial key for 6.7 then please send me screenshot of your Help\About screen so I can see what sort of license you have. Maybe there is another issue we are not aware of.

I hope to hear some good news back from you!

regards
Lidia


#15

That’s right - I am using a trial key so that might be the case. Will try the beta2 and inform you about the results.


#16

ok, where can I download the “Beta2”? :slight_smile:


#17

Here is the post with all the information you need:
http://sqlnavigator.inside.quest.com/thread.jspa?threadID=38064&tstart=0

Lidia


#18

Thanks, that really fixed my problem.
Now I am able to connect to DB.


#19

Dear Sirs Quest

**Please check if it works the indent ’ ’ or un****indent ’ ’

Regards**


#20

Thankyou Carlos

PT40404689 has been raised, looks like this is broken in 7.0 beta
We will fix it for next beta

regards
Lidia