Toad World® Forums

sql query weirdness


#1

OK, not sure you’re going to be able to duplicate this, BUT when I run a query on a very simple table

CREATE TABLE bsd_rpt_parm
(bsd_rpt_intr_no NUMBER NOT NULL,
bsd_rpt_parm_nam VARCHAR2(30 BYTE) NOT NULL,
bsd_rpt_parm_txt VARCHAR2(2000 BYTE) NOT NULL)
NOPARALLEL
LOGGING
MONITORING

– Constraints for BSD_RPT_PARM

ALTER TABLE bsd_rpt_parm
ADD CONSTRAINT bsd_rpt_parm_pk PRIMARY KEY (bsd_rpt_intr_no, bsd_rpt_parm_nam)
USING INDEX
/

Nav appears to go into a hard loop (I have to kill Nav) any time I list the column 3 in the query. I’ve tried it with other tables with a large column, but it doesn’t seem to cause the same problem.

doing an f3 from the navigator will also cause the lock up.

I can do a select off of the column if I use substring. It seems to die if I get too big however. Doesn’t seem like I can get much over 100.

Very weird.

Jet


#2

What kind of data do you have in the third column? Maybe the content is so big that it runs out of memory before it can displays all records.
You can try changing General > Session > Read Buffer Size to fetch a lower number of rows.

Gwen


#3

It’s only returning 14 rows! I doubt it’s a memory problem.


#4

I created the table and insert some dummy data but so far haven’t been able to replicate. Does this make a difference if turn on/off Updateable option? Can you view the data by double click to open the table in table editor?

Gwen


#5

Doesn’t seem to be related to the update feature.

I’m not sure what is causing it. I think I’ll wait for the next beta version and see if it goes away. Must be something just a little different with the table.

I seem to be having trouble generating the sql (ctrl-D) on the tables in this schema also. That seems to be related to the fact that Sql Nav can’t find the primary key index, but if I do a select off of “all_indexes” I can see it. I think something broke here. Only if I’m logged on as the schema owner can I generate DDL for a table it would seem.

Maybe the two are related?

Jet


#6

Hi Jet,

Befor logging in, please tick the ‘Enabled DBA view’ on the Oracle logon page and let me know if it fixes the issue.

Gwen


#7

My user doesn’t have this permission so it gives me an error message when I log

Sorry.


#8

Did you manage to query or extracy ddl from this table using any of the previous release?
How did you find out that sql nav cannot query the primary key index?
Is this possible to provide us with the permissions/privileges that this user have?

Gwen


#9

Ok, the problem with the index not appearing isn’t there today. Must have been a problem on our side the other day.

I can run the query no problem in 5.5.4

Jet


#10

Ok, wait a minute. i can see the index UNTIL I try to extract the DDL. THEN the “generate ddl” fails, and the index disappears from the list.


#11

that’s strange. Please provide the extracted DDL for the user and the table you were using so we can try replicate it here.

Thanks
Gwen


#12

Sent via PM


#13

Hi Jet,

It didn’t cause my environment to lock up but it does give out an error when I tried to extract ddl from the table. Thanks for reporting. We will fix this soon.

Cheers,
Gwen


#14

Interestingly, I can access the table logged on as the schema owner IF I go to the navigator and press F3 on the table.

But, then when I try to sort by a column, or scroll to the bottom everything locks up.

It really doesn’t like scrolling around with big data columns it would appear.

Weird.

Jet


#15

Problem seems to go away if I select “format columns by name width”. I then, seem, to be able to adjust the column manually.

Weird.