Toad World® Forums

Startup problem if ORACLE_HOME not set correctly


#1

Hi,

I have installed the evaluation version, including the back-end, but I can not get it to run, because somehow the ORACLE_HOME is not set correctly.

The problem is that the Quest Code Tester Frontend requires one to login at startup, then tests for the presence of ORACLE_HOME and gives a good error message, including how to fix this (Tools-> … ).

The Frontend closes then however, making it impossible to follow the advice so nicely given . Can anyone tell me how to fix this?

Thanks in advance
Hendrik

orahome_err.bmp


#2

Hendrik -

In 1.6, you can now change the Oracle Home right inside the login window. You might want to immediately switch to evaluating using the 1.6 beta (Click on Quest Code Tester Beta on the left) to see this and use the latest version (we expect to go production in June/July 2007).

I believe there is also a command line option you can use to start up Code Tester and bypass the login window to set the Oracle Home. We will post that information here shortly.

Finally, I believe that there are utilities “out there” allowing you to change your Oracle home, external to any app. Use this, and then start up Code Tester and you should be fine.

SF


#3

Installing the Beta version solved this problem.


#4

Very glad to hear of it!

SF


#5

Anyone who runs into this issue on version 1.5.2 and does not want to download and use the 1.6 beta can manually modify the application configuration file to specify the Oracle home desired.

The application configuration file is named QuestCodeTesterOracle**.ini** and is located in the application folder. It does not exist until the application is first executed and closed with settings to save. If it doesn’t exist, just create a new text file with that name.

If the file exists, copy it to a backup in case you need to revert. The file can also be removed if problems result from erroneous manual modifications and it will be recreated the next time the application is run.

This is a standard ini file format and I will assume you understand the format or can easily find information on the web.

Find or create the Preferences section in the file:
[Preferences]

Find in (or add to) this section an Oracle home name value pair:
OracleHome=MyOracleHome

You can find the correct Oracle home name value in the registry in the following section:
HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE

In there should be one or more Oracle home keys. Mine looks like this:
HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE**KEY_OraDb10g_home1
**Within the home key you should find a string value entry called ORACLE_HOME_NAME. Use the string value as the correct name to use in the QuestCodeTesterOracle.ini file as described above.

Save your changes and then start Quest Code Tester for Oracle and the desired Oracle home should now be used.

Regards,
Greg


#6

Hi Steven, Greg,

Thanks both of you, and Steven, a thank you also for your Düsseldorf presentation, I enjoyed it and will certainly try to apply as much as I can in my work.

Greetings
Hendrik.


#7

Steven,

I don’t know what is the matter with your program but this is already the third year I’ve tried to install your code tester and every year I end up with the same error. I cannot connect to the database. TNS name could not … I give exactly the same data in as in SQLdeveloper and this works fine, your codetester not.
I’ve also looked in the register and my oracleHome_name = Default_home1 (exactly the same as your program indicates).
Even the DBA could not resolve this problemHave you ever tested this on a new machine :-).
I’m a consultant and I’ve already adviced to 5 or 6 companies to NOT buy your program because of this issues.

Can you advice ASAP, please.

greetings

danny, an admirer of your Oracle knowledge
dven@test-aankoop.be

Message was edited by: dven_062


#8

Danny,

I am somewhat amazed to read this posting.

We have 1000s of developers using this tool, clearly it can be installed.

Did you contact Quest Support with your problem?

Please send an email to me at steven.feuerstein@quest.com with a screen shot of the way you are trying to connect, the error you get, etc. I will then open a support ticket and we will work on getting your problem resolved.

Then perhaps you can go back to the 5 or 6 companies you told NOT to buy Code Tester and you can help me change their minds.

:slight_smile:

SF


#9

Steven,

I’ve sent you a mail with the screen shots.
I’m sorry but this takes me today only already 4 hours to read up on everything and something to have this started. I also cannot connect with TOAD so it must be a path problem or something but I’ve had it checked by the dba’s and all seems OK for them. I’ve the same problem at home. I only can connect TOAD to a DB when I’ve have it installed locally. From the moment I’ve to go by the net; it doesn’t work.
So I’ve TOAD installed on my portable but cannot work form there because of the network connection problem.
There is some info that they left out, somewhere in the installation guide.
The amazing thing is, I’ve installed SQLDEVELOPER it works/ I’ve installed PL/SQL Developer it works. So something is missing here.

I hope you can help me

greetings

danny


#10

Hi Danny,

Here is some advice that could help you:
Verify the System path variable contains the desired \bin directory and it is listed at the beginning before any other Oracle directories. Toad uses the path to determine the correct directory and will stop at the first one listed in the path. For example, C:\Orawin95\Bin, C:\Orant\Bin or D:\oracle\ora92\ (depending on if you have Win95, NT Win2k, XP, 2003 Operating System).

To verify the value of the PATH variable, from a DOS prompt type: PATH

If the Oracle client path is not at the front of the entire system path statement, select Start | Control Panel | System | Advanced tab | Environment Variables | from the System Variable list, click PATH | click EDIT and move the Oracle path to the front of the entire entry followed by a semi colon.

Below is an example of the PATH:

C:\oracle\ora92\bin;C:\Program Files\Oracle\jre\1.3.1\bin;D:\C:\WINDOWS\system32;C:\WINDOWS;

Regards,
Lenka