Toad World® Forums

Sticky ARITHABORT OFF setting for all new connections


#1

Hi,

One of my teammember’s install of Xpert edition (6.0.0.323) is suffering from a sticky ARITHABORT situation. Despite our servers (SQL 2012) using the default ARITHABORT ON setting, and despite everyone else’ Toad session having ARITHABORT ON by default, this one user’s setting is always ARITHABORT OFF in any new connection. He can manually set it, of course, but any new tab goes back to ARITHABORT OFF.

We’ve checked that his InitialSqlServer.Sql file has SET ARITHABORT ON, but the setting remains off regardless of whether we check/uncheck the checkbox in Tools -> Options -> Database -> SQL Server.

We’ve tried reconnecting to the server, restarting Toad, to no avail.

Should we try anything else before we blow away the entire app and clean-install it?

  • KJ