Toad World® Forums

Still Not Getting DB on Data Compare


#1

I have attached an image showing a data compare update. As you can see, there is no DB in the DB window. This happens almost all the time. I almost always have to manually select the DB from the (empty) drop-down. If I don’t, it fails. This despite the fact that the data compare knows exactly which DB I am comparing to.


#2

Hi Jonathan,
Thanks for the report. Ive seen this on my side several times, but wasnt able to get exact steps to reproduce. Just played a little bit more and found how to get the same! In my case this issue occurs if I dont have absolutely the same connection in Connection Manager that used in DC project. It may occurs if you deleted a connection or simply modified lets say login or default db.

Does it similar to your case?


#3

This occurs between two servers for me. I am comparing the data on my developer PC to the data on the testing server. I want to push out some new control values, or bring in some new records. I intentionally name the DB instances on my PC differently than the ones on testing. This helps me to avoid accidentally overwriting the wrong DB…

TOAD will pop up the correct connection (the tab and screen colors are correct), but the DB dropdown is blank. It then says that it can’t write to the originating DB. For instance:
I am doing a data compare from my PC to Testing. We’ll call my DB Prog01. We’ll call testing Test01.

I run the data compare, click synchronize, and select to Update Test01. It opens a window with the proper connection to Test01, with the Test01 colors, but no DB in the dropdown. I then try to run the script. This results in an error, something along the lines of not being able to connect to Prog01. It is supposed to be connecting to Test01, but the error is about Prog01.