Toad World® Forums

Strange behaviour of TOAD data grid


#1

Last beta version of TOAD 5.8, but the behaviour was present still in TOAD 5.7.
I connect to a DB, and execute SQL statement as you can see in my 2 screenshot in attach.

I run script and I obtain TOAD1.JPG. See Set 1 in the grid below.
Appear - RUOTA MODULO 9 - .This is not all text contained in the DESART field.
DESART is a varchar(150).
At this point I click on field in the grid and as you cann see in TOAD2.JPG all text appear.
At this point all is OK.

If I execute the same statement in SSMS the result is like TOAD2.JPG.

DESART is a field of a table wich contains about 1500 records.
If I want see the value correctly contained in DESART I can’t click on every records of the table
Are you agree ?

Do you know if there is some options to activate in general options of TOAD to do that ?

I stay tune for your answer.

Best regards.

Sergio Bertolotti

toad1.jpeg

toad2.jpeg


#2

Hi Sergio,

Thank you pointing this out, we understand your concern and are currently discussing how it can be implemented.

As a temporary workaround you can use REPLACE function, e.g.:
SELECT REPLACE (REPLACE(DESART, 0x0A, ’ '), 0x0D, ’ ') FROM ANAGRAFICA_ARTICOLI
It will produce the same results as you can see in SSMS.

We’ll keep you in touch of any updates.


#3

Hi Stanislav,

OK. I’m very happy to see that TOAD team understand the problem.

I sty tune for your consideration or solution in future.

For now I use your suggestion.
Have a nice weekend.

Sergio Bertolotti


#4

Hi Sergio,

I have an update for you. We decided to implement it the next way:

By default line breaks will be replaced by spaces (including line breaks without carriage return symbol). Also there will be an option in the context menu that will allow to turn it off. This feature will be available not only in the results grid of the Editor but also in many other Toad grids where it can make sense. With this feature we also enhanced column fitting in grids to limit columns size, so more columns can be initially shown within the visible area what is handy when they contain much data.

Described enhancements are already implemented and will be available with the first beta of next release.

Many thanks for your contribution!


#5

Hi Stanislav,

I answer to you in TOAD for SQL Server General forum.

Best regards.

Sergio Bertolotti


#6

Dear Stanilav,

I donwload last beta version to test the problem and now has been solved.

Good Works !!!

Best regards.

Sergio Bertolotti