Toad World® Forums

string substitution in packages is in effect again in build 889 !?


#1

Hello again,

  1. Ctrl+Enter works now in sql editor, but still doesn’t work inside package body (neither on package name to open the package nor on procedure name to jump to the procedure). Note - opening package works (inside package body), if the package name is preceded with the schema name. But it should also work without schema name (as in sql editor and as in 5.5).

  2. In package body, can’t print selection. I can’t find no print option under right-click and when doing “File->Print” the “Selection” option in “Print range” is disabled.

  3. Printing again - i copied the selected procedures (506 lines, some wrapping) to an empty editor, and printed from there. Print preview showed 10 pages. I got 10 back from the printer.
    The first page was completely blank. Pages 2-9 printed ok. Page 10 was completely grey. Not black, not white, but gray all over. Checking from print preview - page 1 looks fine. Pages 2-9 also looks fine. Page 9 contains rows 453-506, and if there were more rows, i’d say some 5 rows would have fitted more on that page. Now page 10. This one shows rows from 462-506 - but these rows were already on page 9! And there is a strange broken horizontal line in the print preview on page 10. So actually there should have been 9 pages.

  4. REGRESSION - this bug was in beta 7, was fixed in beta 8 and is now in build 889 again - string substitution in packages
    owa_util.redirect_url(‘owner.package.procedure?p_param1=’||p_param1||’&p_param2=’||p_param2||’&p_param3=’||p_param3||’&pparam_4=’||p_param4);
    becomes
    owa_util.redirect_url(‘owner.package.procedure?p_param1=’||p_param1||’=’||p_param2||’=’||p_param3||’=’||p_param4);

I’m sorry, i can’t use this build any more when saving packages brings along hidden data loss.

Waiting for new build,
Andres


#2

HI Andres,

Welcome back. :smiley:

  1. I checked this issue and these are what I come up with.
  • open package works (with and without schema name)
  • open a stand alone procedure works
  • open a procedure in the same package does not work
    -open a procedure in a different package does not work
    we will fix the bug with open proc but im not sure why you cannot open the package.

2.3. We’re aware that there are several problem with the printing features. However, they are considered as low priority compared to other issues. We will fix them eventually.

  1. I tested it with 5.5 and 5.5 behaves the same. I know you can use substituion with SQL code but not sure it’s applicable to stored program. However SQL nav should not alter the codes like that. Roman will have a look on this bug and may be able to shed light on this matter.

THanks
Gwen


#3

Hi Andres,

The problem with substitution has been fixed now.

Regards,
Roman