Toad World® Forums

Support for DB2_COMPATIBILITY_VECTOR=ORA


#1

Message from: Myles

In v9.7, DB2 provided native support for most Oracle syntax and functionality.
The latest beta version of Toad seems to accept most of these capabilities, but
over several pieces.

In trigger definitions that use the “:new” or “:old” syntax, the program
interprets these as runtime parameters.

Attempting to compile an Oracle package spec and body that are known to be
acceptable to the DB2 client throw all sort of syntax errors. Too many to
describe here.

Is this version of Toad for DB2 intended to support Oracle compatibility?


Historical Messages

Author: Myles Moutoux
Date: Thu Jul 15 14:31:00 PDT 2010
In v9.7, DB2 provided native support for most Oracle syntax and functionality.
The latest beta version of Toad seems to accept most of these capabilities, but
over several pieces.

In trigger definitions that use the “:new” or “:old” syntax, the program
interprets these as runtime parameters.

Attempting to compile an Oracle package spec and body that are known to be
acceptable to the DB2 client throw all sort of syntax errors. Too many to
describe here.

Is this version of Toad for DB2 intended to support Oracle compatibility?

__