Toad World® Forums

TDM beta crashes on start


#1

When I start TDM beta, the splash screen is displayed for a fewseconds, then that goes away and a window appears and then disappearsright away (too fast to see any details), leaving nothing running.

The program has worked before and I’ve been able to reverse engineer anOracle schema. Perhaps it doesn’t like the model it’s trying toopen on startup, but I can’t find any information to indicate what’shappening.

Anyone have any suggestions for gathering more information? I don’t see any log files; are there any? Are there any command line switches, registry keys, etc. to make it start without loading a model?

The tdm.exe file has version 3.0.1.415.

Thanks.

Rodney


#2

Hello Rodney,

The program has worked before and I’ve been able to reverse engineer anOracle schema. Perhaps it doesn’t like the model it’s trying toopen on startup…

Information about model when closing the application + settings of the application layout are saved to the TDM.txe file.
(Possible path:
C:\Documents and Settings\current user\Application Data\Quest Software\Toad Data Modeler\Configs)

Please delete the .txe file and then try to run TDM again. -> The default .txe file will be called and copied from the installation package again.

This should help.

Nevertheless, if the problem still remains, please delete the all Configs folder.

Then feel free to update your BETA and install the latest BETA 3.0.2.221 from:
http://modeling.inside.quest.com/ann.jspa?annID=86&sid=96da4eb2-6c08-4464-9b7f-b7287f3f1593

Please let us know the result. Thanks!

Regards,

Vladka


#3

Installing the new beta fixed the problem and I am unable to reproduce it now.

Thanks.

Rodney


#4

Hi Rodney,

Thanks very much for letting us know the result, and also for taking the time to try to reproduce the problem.

We’re glad to hear TDM 3 Beta works properly now.

In case of ANY trouble, please write us. Also, any suggestions on enhancements are greatly appreciated!

Regards,

Vladka & TDM Team


#5

I’ve been using TDM Beta 3.2.3.9 for weeks now and this morning i rebooted my windows machine after a windows update. Now I am encountering a failure on startup of the TDM beta. I am not sure if it was related to the windows update or not but its certainly possible. I tried removing the TDM.txe file as described above but the startup still fails. I’ve attached the error details below. I will next try downloading and installing the latest beta to see if that helps.

-Jeff Ryan

EurekaLog 6.0.14

Application:

1.1 Start Date : Thu, 17 Jul 2008 14:37:44 -0500
1.2 Name/Description: TDM.exe - (ERD Designer)
1.3 Version Number : 3.2.3.9
1.4 Parameters :
1.5 Compilation Date: Wed, 11 Jun 2008 08:51:11 -0500
1.6 Up Time : 17 seconds

Exception:

2.1 Date : Thu, 17 Jul 2008 14:38:02 -0500
2.2 Address :
2.3 Module Name : TDM.exe - (ERD Designer)
2.4 Module Version: 3.2.3.9
2.5 Type : EAccessViolation
2.6 Message : Access violation at address 00000000. Read of address 00000000.
2.7 ID : 1DC3
2.8 Count : 1
2.9 Status : New
2.10 Note :

User:

3.1 ID : jeffry
3.2 Name : Digi User
3.3 Email :
3.4 Company : Digi International
3.5 Privileges: SeChangeNotifyPrivilege - ON
SeSecurityPrivilege - OFF
SeBackupPrivilege - OFF
SeRestorePrivilege - OFF
SeSystemtimePrivilege - OFF
SeShutdownPrivilege - OFF
SeRemoteShutdownPrivilege - OFF
SeTakeOwnershipPrivilege - OFF
SeDebugPrivilege - OFF
SeSystemEnvironmentPrivilege - OFF
SeSystemProfilePrivilege - OFF
SeProfileSingleProcessPrivilege - OFF
SeIncreaseBasePriorityPrivilege - OFF
SeLoadDriverPrivilege - ON
SeCreatePagefilePrivilege - OFF
SeIncreaseQuotaPrivilege - OFF
SeUndockPrivilege - ON
SeManageVolumePrivilege - OFF
SeImpersonatePrivilege - ON
SeCreateGlobalPrivilege - ON

Active Controls:

4.1 Form Class : TApplication
4.2 Form Text : Toad Data Modeler Beta
4.3 Control Class: TApplication
4.4 Control Text : Toad Data Modeler Beta

Computer:

5.1 Name : ROC-CMS-JRYAN
5.2 Total Memory : 3055 Mb
5.3 Free Memory : 1650 Mb
5.4 Total Disk : 74.53 Gb
5.5 Free Disk : 25.7 Gb
5.6 System Up Time: 7 hours, 2 minutes, 47 seconds
5.7 Processor : Intel® Core™2 CPU 6300 @ 1.86GHz
5.8 Display Mode : 1920 x 1200, 32 bit
5.9 Display DPI : 96
5.10 Video Card : Radeon X1950 Series (driver 8.291.0.0 - RAM 256 MB)
5.11 Printer : Brother MFC-9700 USB (driver 6.0.5824.16384)

Operating System:

6.1 Type : Microsoft Windows XP
6.2 Build # : 2600
6.3 Update : Service Pack 2
6.4 Language: English
6.5 Charset : 0

Network:

7.1 IP Address: 010.020.001.050
7.2 Submask : 255.255.255.000
7.3 Gateway : 010.020.001.001
7.4 DNS 1 : 010.010.008.062
7.5 DNS 2 : 024.159.193.040
7.6 DHCP : OFF

Call Stack Information:

|Address |Module |Unit |Class |Procedure/Method |Line |

Running Thread: ID=4260; Priority=-2; Class=; [Main]
7E41DAF4
7E41DAEA
004EEF1B
004EEF14
004EF1A7
7C90E64C
----------------------------------------------------------------------------------------------------------
Running Thread: ID=5692; Priority=0; Class=TExplorerNotifierThread
----------------------------------------------------------------------------------------------------------
7C90E9A9
7C80952A
7C80A070
7C80A05D
006645D1
----------------------------------------------------------------------------------------------------------
Calling Thread: ID=4260; Priority=-2; Class=; [Main]
----------------------------------------------------------------------------------------------------------
006644F5
00664454
00664266
0066422C
0066465E
00664628
006646CD
0066436D
00664358
00664225
00664220
00DB193A
00DAF491
00E9E685
00E9E37C
00F28DF8
7C90E64C
----------------------------------------------------------------------------------------------------------
Running Thread: ID=3000; Priority=0; Class=TExplorerNotifierThread
----------------------------------------------------------------------------------------------------------
7C90E9A9
7C80952A
7C80A070
7C80A05D
006645D1
----------------------------------------------------------------------------------------------------------
Calling Thread: ID=4260; Priority=-2; Class=; [Main]
----------------------------------------------------------------------------------------------------------
006644F5
00664454
00664266
0066422C
0066465E
00664628
006646F9
0066436D
00664358
00664225
00664220
00DB193A
00DAF491
00E9E685
00E9E37C
00F28DF8
7C90E64C
----------------------------------------------------------------------------------------------------------
Running Thread: ID=4572; Priority=0; Class=TExplorerNotifierThread
----------------------------------------------------------------------------------------------------------
7C90E9BE
7C90D527
7C802540
7C80252D
7C802520
00664579
006645ED
----------------------------------------------------------------------------------------------------------
Calling Thread: ID=4260; Priority=-2; Class=; [Main]
----------------------------------------------------------------------------------------------------------
006644F5
00664454
00664266
0066422C

#6

Hi Jeff,

Beta 3.2.3.9 expired some days ago. Please download Beta 3.2.3.10.

Please let me know if the problem is solved then. Thanks.

Regards,

Vladka