Toad World® Forums

TDP 4.1 Automation Nested Automation Jobs- Skipping

I have an automation job named “AM_ALL”, embedded in it are 7 automation jobs (nested). Today, I learned that the jobs are not running in the order in which they are setup in the “AM_ALL” TAS file. Moreover, the automation file “AM_ALL” completed without running all of the nested automation jobs. This occurs when the jobs are scheduled with Windows Task Scheduler. Any thoughts on this issue?

i have never seen that before. The Automation engine is very sequential and based on the skip. Can you run the script(s) with verbose logging and then open a support case? We would need to investigate. Even if you used the Parallel activity everything is run sequentially. I would also check what the stop on error and generate error options are set to.

Your script is set to continue on error. I have never seen jobs jump out of order. I have seen some jobs run longer than others one day and not the next. I might suspect that you have more than one AM_ALL scheduled and they are running over each other. Run the windows task scheduler and check there for duplicate tasks.

I have had this happen to me before but on an old version. It would skip some automation jobs in the master job and not send any error messages or anything to indicate that something went wrong. I also had to set up the logging so all of the called jobs did not truncate the log file. I did not experience steps running out of order, it may appear that way because of jobs getting skipped but it does not go back and start an earlier job later. Wish I could remember the version and the fix, I was at a different company when this happened. I am guessing 2.8 or maybe 2.8 was when it was fixed? Sorry I can’t be of more help. What version are you running?

Having a similar problem. Recently upgraded from TDA 2.7 to TDP 4.1, have about 30 jobs in automation and all migrated without issue. However, yesterday I created six separate queries using two different oracle connection and put into automation. After I completed building the automation it ran flawlessly. I then scheduled the automation and tried to run the task from the Job Manager and would not run, says it’s running but it never does and never stops. Tried running the task from Task Scheduler and same issue. Checked this morning and it did not run but shows it’s been running since 2:45am this morning. Stopped the process; opened the automation file and ran it from there with no issues.


Could you please enable verbose logging and open a support ticket? We would need to investigate the logs to find out, what’s wrong.