Toad World® Forums

[TDP Beta 3.3.1327] [Run Program] Batch File still appears to be broken


#1

I have a Run Program activity in a TDP 3.3.1327 automation script (brand new, not imported from a previous version), and I still cannot get the execution of the batch file to work correctly (problem was first observed in TDA 3.1).

The log file for the Automation script seems to indicate that the batch file was executed successfully (see picture “TDP 3.3.0.1327 Run Program - Batch File.jpg”).

But when I go to the destination directories - no files or directories are present.

I’ve also attached a screen cap of the configuration of the Run Program activity (see picture “TDP 3.3.0.1327 Run Program - Batch File Settings.jpg”).

The batch file itself only consists of the lines you can see in the log file capture.

TDP 3.3.0.1327 Run Program - Batch File Settings.jpeg

TDP 3.3.0.1327 Run Program - Batch File.jpeg


#2

I remember running into this myself several years ago. For some reason XCopy will not work. I ended up having to use some other function. I can’t remember how I solved it but we never figured out on this end how to get that one function to work. All other dos functions were okay.

Debbie


#3

Could it have something to do with the way the batch file execution is processed?

I know it is a “Run Program” activity, so the intention is to be able to run all sorts of external programs, but - if the batch file is essentially being run directly from the equivalent of Start -> Run, then that may be the issue - because if I first open a CLI window (CMD.EXE) and then run the batch file from there, it works just fine.

Additionally, the work around I’ve found (building a scheduled task to execute the batch file), does that - Windows first calls CMD.EXE and then passes it the name of the batch file (from what I understand after diving deep into how SCHTASKS works).

Of course, once Copy File is fixed, this will be moot (for me at least) for now, but it could come back in the future.


#4

Have you tried using cmd.exe as the calling program and your bat file as the program arg? Try that and see if that makes a difference.

Debbie


#5

I just did - that doesn’t work either.