Toad World® Forums

The passwords for the connections are not saved


I have installed the last version of Toad Xpert with DB Admin. I have a big problem because my passwords for the connections are not saved. And more the probleme is intermittent!

Can someone help me please!

My poste is in Windows 7 et I’m not the system’s administrator.

Thank’s very much.

Christiane Pépin
Administratrice de bases de données
Direction du développement
Direction principale des systèmes d’information
Ministère des Finances

8, rue Cook, 3ième étage, 3.09-C Québec (Québec) G1R 0A4

Téléphone : 418 646-4244
Télécopieur : 418-644-3964

Is “Save Passwords” checked? It’s at the bottom of the login screen.

i tried upgrade to 13.3 (from 13.1.*) for oracle this morning and the upgrade did not complete successfully. However, it wiped out all my saved connection passwords. I have over 10 connections saved. I tried re-import what I exported a few weeks ago but it doesn't do anything. How can I remove all the saved connection and re-import.

Export/Import toolbar buttons are shown below:

In 13.1, Export to file.
In 13.3, Import the file.

To delete connections, CTRL+A in the grid, then hit Delete key.

Thank you. That fixed my problem.

After working fine for a couple of days. The saved connection passwords are messed up again. I went to connect and got the invalid password error. I had to update the password again. Why is it not saving the passwords any more? Until my attempt to upgrade, I never had this issue. Any ideas?

Is the "save passwords" checkbox on the login window checked? It needs to be.

Have you logged into windows using a different user name? The encryption/decryption of passwords is tied to that, so Toad won't be able to decrypt passwords if they were encrypted under a different windows user.

I don't know of any problems in Toad with saving of passwords.

Yes, the save password was checked. I rechecked it two days ago when I had to reimport the connection strings. This happens during the first morning login when Toad tries to "recover" some lost sessions which BTW never worked. Now I asked Toad to removed the old sessions perhaps it will start to work.
I only have one windows account/credential.

By "Sessions" do you mean text in the Editor?

This finally starts to work after I got rid of all the old editor sessions toad was trying to recover.

If you can provide some steps to reproduce the problem, we will try to fix it.

Is it something like this? Please correct me if this is wrong.

  1. type stuff in editor but don't save, wait a few minutes. (to create editor contents recovery file)
  2. kill Toad (so Toad will prompt to recover editor contents on next start)
  3. change password from SQL Plus
  4. start Toad with auto login (supply new password when asked)
  5. double-click to restore the saved editor contents
  6. Close and restart Toad to see if changed password is saved

sort of but not exactly. If it happens again, I will try to remember the steps. After my attempt to upgrade to toad 13.3 failed, I had a lot of trouble saving the passwords. It is now finally working , keep my fingers crossed.