Toad World® Forums

Toad 5.8.0.805 Version Control Issues


#1

Version control still doesn’t work in the lastest beta version. I didn’t copy settings, I setup version control to SVN from the wizard as suggested. When I click on any object that is under version control I get the same two errors popping up multiple times.

System.ApplicationException
Unable to locate UpdateFolder template.
Stack Trace:
at Quest.VersionControl.CommandTemplate.CommandTemplateProvider.UpdateFolder(String folder, String revision)
at Quest.Toad.VersionControl.RepositoryManagerFileProcessor.EnsureRepositoryHasLatestRevision()
at Quest.Toad.VersionControl.RepositoryManagerStatusProcessor.RefreshObjectStates(Object refreshObjectStatesParms)

System.InvalidOperationException

Unable to locate “GetFolders” template.
Stack Trace:
at Quest.VersionControl.CommandTemplate.CommandTemplateProvider.GetStatus(String folder)
at Quest.Toad.VersionControl.RepositoryManagerFileProcessor.DeleteNotCurrentSqlFiles()


#2

I was able to make an initial import of all objects, but I’m now having trouble doing a subsequent commit. The issue seems limited to just tables because attempting to do a Diff on a table brings up what looks to be the exact same error:

Quest.Shared.Processing.CallStackSaverException
Problem with load IndexesScript
Stack Trace:
at Quest.Toad.SqlServer.Common.SchemaModel.Converter.Facade.FacadeHelper.GetScripts(IConnection connection, List1 trls, Dictionary2 result)
at Quest.Toad.SqlServer.Common.SchemaModel.Converter.Facade.FacadeHelper.GetScripts(IList1 trls) at Quest.Toad.SqlServer.SqlServerVersionControlExtension.GetScripts(IList1 trls)
at Quest.Toad.VersionControl.RepositoryManager.d__11.MoveNext()
at System.Linq.Enumerable.First[TSource](IEnumerable`1 source)
at Quest.Toad.VersionControl.VCStaticExtensions.VCGetDbScript(ITrl trl)
at Quest.Toad.VersionControl.Actions.Diff(Object sender, ITrl[] trls)

Quest.Shared.Processing.CallStackSaverException
Problem with load IndexesScript
Stack Trace:
at Quest.Schema.Common.OnionMechanism.Modules.Module.RunAsync(ICallBack callback, OnionContainer container, Object[] args)
at Quest.Schema.Common.Facade.FacadeOperations.Operation_LoadSources(ICallBack callback, FacadeRunContext context, SourcesArguments arguments)
at Quest.Schema.Common.Facade.FacadeOperationMap.OperationRunner`1.RunOperation(ICallBack callback, FacadeRunContext context, Arguments arguments)
at Quest.Schema.Common.Facade.FacadeOperationMap.RunOperation(Operation operation, ICallBack callback, FacadeRunContext context)
at Quest.Schema.Common.Facade.Facade.OperationRun(Operation operation, ICallBack callback, FacadeRunContext context)

Quest.Shared.Processing.CallStackSaverException
Problem with load IndexesScript
Stack Trace:
at Quest.Schema.Common.Modules.SourcesLoader.SourcesLoaderModule.LoadSources(ICallBack callback, SourceInfoCollection collection, MultiThreadingOptions threadOptions, SourceModelCollection models, OptionsStorage options)
at Quest.Schema.Common.Modules.SourcesLoader.SourcesLoaderModule.RunProcess(ICallBack callback, OnionContainer container)
at Quest.Schema.Common.OnionMechanism.Modules.Module.RunAsync(ICallBack callback, OnionContainer container, Object[] args)

Quest.Shared.Processing.CallStackSaverException
Problem with load IndexesScript

System.ApplicationException
Problem with load IndexesScript
Stack Trace:
at Quest.Schema.Common.ModelLoad.ModelLoader6.Run(ICallBack callback) at Quest.Schema.Common.ModelLoad.ModelLoadManager7.Loader.LoadModel(ICallBack callback)
at Quest.Schema.Common.ModelLoad.ModelLoadManager`7.CreateInstance(ICallBack callback, SchemaSnapshot snapshot, ISingleModel model, OptionsStorage options)
at Quest.Schema.MSSQL.ModelLoad.ModelLoadServiceMSSQL.Create(ICallBack callback, SchemaSnapshot snapshot, ISingleModel model, OptionsStorage options)
at Quest.Schema.Common.Modules.SourcesLoader.SourcesLoaderModule.LoadModelFromSnapshot(ICallBack callback, SourceLoader source)
at Quest.Schema.Common.Modules.SourcesLoader.SourcesLoaderModule.SourceLoader.Run(ICallBack callback)

System.NullReferenceException
Object reference not set to an instance of an object.
Stack Trace:
at Quest.Schema.Common.Model.SingleModel3.Add(Item3 parent, Int32 typeIndex, String name, Int32 id)
at Quest.Schema.Common.ModelLoad.Declarations.ObjectLoaders.CommonObjectLoaderWithExtension5.LoadObject(DataReader1 reader, TLoadContext context, ParentSearchContext1 searchContext) at Quest.Schema.MSSQL.ModelLoad.LoadModel.Declarations.Process.ObjectLoaders.ObjectLoaderIndexes.LoadObject(DataReader1 reader, LoadContext context, ParentSearchContext1 searchContext) at Quest.Schema.Common.ModelLoad.Declarations.ObjectLoaders.CommonObjectLoaderBase5.LoadObjects(ICanceling cancel, DataReader1 reader, TLoadContext context) at Quest.Schema.Common.ModelLoad.ModelLoader6.Run(ICallBack callback)


#3

Turns out my issue was related to UDDT. I had one I’d made long ago and forgotten about. Fortunately, it wasn’t being used, so I was able to drop it and now version control is working fine.


#4

Hi mcarillon,

Can you please make sure you have command definition “UpdateFolder” in this file:
\Templates\VersionControl\Subversion.xml
?
can you also share with me your file?


#5

Message was edited by: mcarillon


#6

Valentine, I uninstalled, removed all directories related to 5.8 Beta and reinstalled the application. I made sure not to copy configuration from 5.7. Now I no longer receive the errors about Updatefolder and GetFolders templates.

But version control doesn’t seem to be working like it does in 5.7. For instance under Options for Version Control, it only has one page, Configurations. All fields are dimmed except for username and password. I can only add a configuration using the Version Control wizard. Once a configuration is added I can’t make any changes to it through the Options, Version Control, Configuration section. Also the only Configuration Type available is Database Level. I can no longer add a Server Level Version Control configuration.

When viewing my items in Object Explorer that are in Version control, there is a little icon by them that is orange and has a ? in it. While viewing the script for a version controlled item in Object Explorer, there is no section for Version Control information at the bottom of the Script window.

-Mike


#7

Hi Mike,

Good to know you have finally workaround your original issue.
Version Control really looks different from previous release.
you’ve bring good point about editing Version Control configuration.

Can you please let me know what objects you were looking for to put under Version Control? Also can you please let me know what you are referring to by saying “there is no section for Version Control information at the bottom of the Script window.” - you may just attach image.


#8

This one is fixed in dev environment also)))


#9

I really wasn’t looking for any setting in particular, I just noticed the big difference between the two versions. I noticed Server Level configuration is gone and you can only setup Database Level configuration. Would you explain the differences between the two?

Also I just can’t get Version Control to work in 5.8 Beta. Like I said, my items that are in Version Control show with an small orange icon with a ‘?’ mark in them. Nothing seems to work for me. But on the same machine running 5.7, Version Control works just fine.,
toadvc.jpeg


#10

Hi mcarillon,
let me try to answer your questions. First of all, starting from 5.8 version Version Control has several limitations in compare to previous version:

  1. Server Level is no longer supported
  2. Version Control settings can’t be edit after set up. To edit something - please recreate it.
  3. Toad can’t work with Version Control settings from previous versions. So you have to set up your configuration one again in 5.8
  4. at 5.8 toad can’t properly read current object revision in case of parallel using the same repository from previous Toad version

I hope I’ve answered your questions. If you still have any in TSS 5.8 - let’s start from the begining, but taking this information into the account.

regards,
Alexander


#11

Issues with new Version Control

  • Functions that return a table “Returns Table” aren’t able to be added (committed) to Version Control.

  • The “Commit to Version Control” dialog that pops up requires a comment but this isn’t clear to the user. The progress bar in the lower right corner of the application is animated and shows “1 task” in the progress bar like some operation is happening in the background. Even under the Background Processes window, it shows a “Commit to version control” operation is executing but actually what is happening is the “Commit to Version Control” is just sitting there waiting for user to add a comment to complete the operation. Once a comment is added the “OK” button on the dialog is enabled and the user is able to click “OK” for the operation to get under way.

  • Please add an option to not require comments for version control commit. This should be an user option, it shouldn’t force the user to enter comments if the user doesn’t want to add comments.


#12

Hello mcarillon,
sorry for the delay. It took me a bit longer to get to this thread again. Regarding your last response - we’ve created CRs to all three items (104842, 104843, 104845).

Thank you for the input.