Toad World® Forums

Toad Add-In for SQL Server FileNotFoundException

Opening SSMS for SQL Server 2014. Get this error:


Toad for SQL Server: FileNotFoundException

FileNotFoundException

Could not load file or assembly ‘SqlPackageBase, Version=11.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91’ or one of its dependencies. The system cannot find the file specified.


OK

I get this message after uninstalling toad

Any update on this? I’m experiencing this error and have not been able to find a solution. Thanks!

I just checked, this is still a problem in build 6.6.0.291.

Hi Darren,

We have created an issue(TSS-732) for it before, but haven’t fix it yet.

I will mark it as priority 1 and we will try to fix soon.

Sorry for the inconvenience.

Thanks,

Cathy.

Build 6.6.0.371 Still get error on launching Microsoft SQL Server Management Studio 2014:


Microsoft SQL Server Management Studio


The Add-in ‘Dell Toad Add-in’ failed to load or caused an exception.

Would you like to remove this Add-in?

If you choose yes, the file it was loaded from, ‘C:\ProgramData\Application Data\Microsoft\MSEnvShared\Addins\Dell.ToadSSMSAddin.AddIn’, will be renamed.

Error Message: The system cannot find the file specified.

Error number: 80070002


Yes No


What’s strange: I tried opening SSMS as administrator … I got the same error message.

But then I tried running sysinternals procmon.exe tool to see if I could figure out what file it thinks is missing but this time when I opened SSMS (not as admin) this time it just opened with no error (for the first time in months).

I then proceeded to look for the add-in in SSMS, but couldn’t find it.

What specifically should I be seeing in SSMS when the add-in does load successfully?

Has there been any progress on the “TSS-732” issue fix? I uninstalled Toad months ago, but more recently when I upgraded to SSMS 2014, I started getting the error (in this thread).

Hi,

For TSS-732. We are looking at this. And we will fix in 6.6 Release. Sorry for your inconvenience.

Best Regards,

Kelly

Build 6.6.0.604 still has this issue. Since clicking “Yes” to the Microsoft message asking to remove it produces error:


Microsoft SQL Server Management Studio


Could not rename Add-in file ‘C:\ProgramData\Application Data\Microsoft\MSEnvShared\Addins\Dell.ToadSSMSAddin.AddIn’.

If problem persists, please contact your system administrator.


OK


What is the recommended method for getting rid of the error? Just un-installing Toad 6.6 then re-installing without that option? Is there a faster hack we can use?