Toad World® Forums

TOAD disallows white space in my type declarations

Hi there,

Types are code like anything else and white space is nice. Is there a reason Toad 12.9.0.71 no longer allows empty newlines in a type declaration? is this a setting I need to turn off somewhere? Running it as “execute as script” gets around the issue.

Thanks,

Paul

CREATE OR REPLACE TYPE echo_swagger_typ FORCE
AUTHID CURRENT_USER
AS OBJECT (
swagger_id VARCHAR2(255 Char)
,echo_module VARCHAR2(255 Char)
,swagger_version VARCHAR2(255 Char)
,info_version VARCHAR2(255 Char)
,info_title VARCHAR2(255 Char)
,info_description VARCHAR2(255 Char)
,swagger_host VARCHAR2(255 Char)
,swagger_base_path VARCHAR2(255 Char)
,schemes_https VARCHAR2(5 Char)
,consumes_json VARCHAR2(5 Char)
,consumes_xml VARCHAR2(5 Char)
,produces_json VARCHAR2(5 Char)
,produces_xml VARCHAR2(5 Char)



,CONSTRUCTOR FUNCTION echo_swagger_typ
RETURN SELF AS RESULT



,MEMBER FUNCTION toJSON(
p_pretty_print IN NUMBER DEFAULT NULL
) RETURN CLOB

);
/

This is fixed for 12.10. In 12.9 you need to disable the “Treat blank line as statement terminator” option on the Execute/Compile page in Options.

Michael

Thanks!

I must say opening up a type declaration that has been around forever and seeing nothing but red exclamations everywhere is a little disturbing.

Cheers,

Paul