Toad World® Forums

Toad for Oracle 12.10. suddenly menu is freezing


Win 10, toad 12.10, working for months, suddenly menu is freezing/ hanging up. Click File, the submenu does not drop down. Tried uninstalling, reinstalling and it does not fix. Any ideas?



Do any of the menus work? When it freezes, is Toad hung completely and you must kill it or is it just the File menu that is seemingly unresponsive?

If File menu is only thing affected you can try the following.

  1. Right-click on the main Toad toolbar and choose "Restore defaults" -- in case the File menu is actually OK, but has become corrupt and contains no items.
  2. Close Toad, open Toad.ini in a text editor, and remove the entire [EditorMRU_Files] INI section -- in case there are some files listed in there that are no longer accessible (network drives, deleted, etc.). Current Toad does not validate these recently opened files' existence when the File menu is shown, but older Toad may have, I can't recall. Toad.ini will be located here by default... %APPDATA%\Dell\Toad for Oracle\12.10\User Files\Toad.ini.


All menu's freeze. Have to kill via task manager.


If you're able to get to the Utilities menu without it freezing.. Utilities > Copy User Settings... then in the dialog check Reset to a clean set of user files from the base installation and hit OK.

Note that this will reset everything.


The manual way to do that is:

  1. Close Toad if it is running.
  2. go to C:\Users\your user name\AppData\Roaming\Dell\Toad for Oracle\12.10, and rename it.
  3. find C:\Program Files\Dell\Toad for Oracle 12.10\ClientFiles and COPY (not move) to the old location from step 1.
  4. start Toad and it will look freshly installed.

Your paths may differ slightly.


Thank you! restoring the defaults worked!


A weird update, when toad is full screen, the menus still freeze, but if it is NOT full screen they don't freeze. So it's working but displaying strange behavior.