Toad for SAP Solutions ( IQ connection problem )

I’m trying to connect to Sybase IQ 16 with Toad for SAP Solutions 3 from my laptop as a client.

After setting up all connection manager fields I’m getting a massage which states…

Do i need an ODBC connection on my laptop (client side?)

Note: with same connection settings Aqua Data Studio connects without any problem.

Hello sonic_spin,

You don't need an ODBC to connect from Toad to IQ.

According to the error message it seems that the Server (server name) parameter isn't set correctly in the Connection Properties dialog:

The server name is specified as a parameter for the start_iq (database server startup) utility on the database server after the -n switch:

Thanks for your reply….

I’ve downloaded and installed Toad for SAP Solutions Beta 3.1.

Surprisingly I’ve created the connection to IQ16 and it worked!

Then I exported the connection to My Connections.xml and re imported it to Toad for SAP Solutions it fails to connect with an error

So I closed the evaluation version again and re-opened the beta. Surprisingly it never connected again!! Giving the same error

Toad for SAP Solutions is installed on my laptop on an OS Windows 8.1 PRO 64 bit.

I’m going to install on another platform and see if the problem persists.

Hello Geoffrey,

This is really odd. Unfortunately we are not able to reproduce the error.

Could you please check, if the Server parameter is still the same, or if it has been changed somehow?

What is the exact version of the IQ server?

Are you able to connect for example with Interactive SQL (Sybase client for IQ)?

Hi Libor,

Currently we are in a transition phase and have two databases, Sybase 15.2 and Sybase 16.

This is really weird … this morning Toad for SAP Solutions connected to the 16 and cannot connect to the 15.2.

On the same laptop with the same imported My Connections.xml, the beta doesn’t connect to none of them.

Hi Geoffrey,

Have you managed to try Interactive SQL as I wrote in the previous post to connect?

Since the error you are getting is not consistent it looks like it’s not related to Toad, in which case we unfortunately couldn’t help you.

Let us know how it works out.


HI, Libor,

i guess is a software conflict of some sort, because Toad sometimes connects other times don’t (example after restart). I have other clients to connect to Sybase IQ16 and they work fine. i would recommend to have the option to connect toad trough a system ODBC.

Hi, Geoffrey.

We’re very sorry to hear about your inconsistent connections. While connecting using an ODBC driver might resolve the physical connection use of the product it would also impact other functional areas of Toad where the ODBC driver does not provide the same capabilities as the native driver. This is why all of our Toad products designed for development or DBA tasks always use a native driver and not an ODBC connection. We do not offer the ability to chose which driver as this would add too much overhead to each feature to first check what type of connection exists and whether we would need to disable that feature.

If you just need basic connectivity to run a query or browse objects, I would recommend you check out our Toad Data Point product. It, too, uses a native connection by default but you can also define custom ODBC connections.

Best regards,


It sounds like you have found some bug that we are not able to reproduce. Can you open a support case so we can gather the information we need to fix this? Please let support know what Server Pack your IQ server is on as i think there are some issues with SP10.

Hi Steve / Debbie,


SAP IQ/ Linux64 - x86_64 - 2.6.18-194.el5/64bit/2015-05-14 11:56:59

We have the same problem on Win7 machines. It does not connect through Toad but connects with iSQL.

More interestingly sometimes Toad connects after making a connection with iSQL.

Toad for SAP Solutions

SAP IQ/ 2003/64bit/2015-01-29 21:18:10

try to set broadcast = NONE

Did this resolve the issue?


it worked thanks

@Debbie Peabody

for me yes

It helps me too thanks :smiley: