Toad World® Forums

Toad for SQL Server Beta 6.6.0.441 - Problem to debug stored procedure


#1

Today I try to debug a stored procedure.

I select it and via right button select - Debug.

Afte rinsert a correct value for the parameters the process begin and cursor goes to the first instrucion, line yellow.

See my screenshot in attach for detail :

start_debug.jpeg

As you can see connection manager and object explorer Windows have a correct size.

At this point I press F8 button on my keyboard to Step Over instruction, but there is a problem

I attach a screenshot of this :

when_debug.jpeg

Connection manager window was resize to small, object Explorer window is maximized and focus is in object Explorer over label - Contains Like.

The step of instrucion is halted to same line - create table #tmptick(codice int)…

This happen only if I press F8 button on the keyboard of my notebook.

If I continue to press F8 on my keyborard the behavior is the same.

If I press - Step Over - button on the toolbar of the debug window all is OK.

Windows of Connection and object Explorer are the same sizebeore to press F8 button on toolbar and instruction goes to the next line correctly.

I stay tune for your consideration,

Best regards,

Sergio


#2

Hi Sergio,

Thank, we already have issue TSS-580 for this problem but it haven’t been fixed. Sorry for your inconvenience. We will discuss how to fix it.

Best Regards,

Kelly


#3

Hi Kelly,

many thank’s or your support.

I test it in new version of TOAD SS Beta to see if the problem will be solved.

Have a beatiful 2015.

Best regards,

Sergio


#4

Hi Kelly,

I test the same steps in TOAD Xpert 6.5 and the problem is the same.

If new UI generate this little but annoiyng problem, I prefer the old UI.

Best regards,

Sergio


#5

Hi Sergio,

Thanks, I rank higher for TSS-580, but it seems hardly to fixed it in next beta build. Sorry for this. And for the new UI, this change is from toad studio, not only Toad for SQL Server. We try our best to avoid and fix these UI issue. Sorry for your inconvenience.

Best Regards,

Kelly


#6

Hi Kelly,

many thank’s for your support.

I hope to see problem will be solved for the final new release of TOAD SS.

Best regards,

Sergio


#7

Hi Kelly,

Toad for SQL Server Beta 6.6.0.604 and the problem is still present.

Best regards,

Sergio


#8

Hi Kelly,

Toad for SQL Server Beta 6.6.0.920 and the problem is still present.

Best regards,

Sergio


#9

Hi Kelly,

Toad for SQL Server Beta 6.7.0.65 and the problem is still present.

Do you plan to fix it for the final version 6.7 of TOAD SS?

I stay tune for your answer,

Best regards,

Sergio


#10

Hi Sergio,

Thank you for testing. Sorry for this bug still not been fixed.

Yes, We plan to fix this in 6.7 version.

Best Regards,

Kelly


#11

Hi Kelly,

good news.

Best regards,

Sergio