Toad World® Forums

Toad for Sybase 1.4 - no Connection Automation with x64 Windows 7 and ODBC Drivers


#1

Hello,

Recently I had to switch from using

Toad for Sybase 1.3 on a Windows XP x86 machine with 32 bit odbc drivers installed

to

Toad for Sybase 1.4 on a Windows 7 x64 machine with 64 bit odbc drivers only.

While Automation of file and system activities still works like a charm I don’t seem to be able to automate database activities. Execution of any automation script including any kind of database activitiy fails with the folling error message:

“Exception has been thrown by target of invocation. File or Assembly “Interop.MSScriptControl, Version=1.0.0.0, Culture=neutral, PublicKeyToken=c862883b2ae69822” or a dependency could not be found. Cannot load file.”

Task Manager Shows that Toad for Sybase is run as a 32 bit application.

Is there any way to fix this?

Thanks in advance.

Martin


#2

Hello Martin,

Would you be able to send me a support bundle? These can be generated under the Help menu item.

I will also try to reproduce the issue here.

Thanks.


#3

Dear Mr. Garza,

Thank you for offering your help on the issue. Please find enclosed

the support bundle generated via the Help menu of my Toad for Sybase
installation.

Best regards,

Martin Schulze

  Am 21.08.2013 09:32, schrieb Michael

Garza:

RE:
Toad for Sybase 1.4 - no Connection Automation with x64
Windows 7 and ODBC Drivers

Reply by Michael Garza
Hello Martin,

        Would you be able to send me a support bundle?  These can

be generated under the Help menu item.

I will also try to reproduce the issue here.

Thanks.

To reply, please reply-all to this email.

      [            Stop

receiving emails](http://gyk.r.mailjet.com/redirect/xltoh81cbfvhlwlf86c0nf/www.toadworld.com/products/toad-for-sybase/f/24/t/20152.aspx?subscribe=false) on this subject.

      Or [            Unsubscribe

from Toad for Sybase - General](http://gyk.r.mailjet.com/redirect/fr92tf2bnhrc31rl8b24j8/www.toadworld.com/products/toad-for-sybase/f/24.aspx?subscribe=false) notifications altogether.

      Toad for Syabse - Discussion Forum
    Flag

this post as spam/abuse.

  ![](http://gyk.r.mailjet.com/0630fdec/4wzLsV.gif)

#4

Thanks Martin, I will look at this and get back to you.

BTW, we recently released version 2.0 if you would like to try that out and see if you have the same issue.

Thanks again.


#5

Hello Martin,

Parts of Automation use the Microsoft script control and we do not install it with Toad. You can download it from the link below. After installing Automation should work just as before.

Please let me know if you have any issues.

Thanks.

Script Control download: www.microsoft.com/…/details.aspx