Toad World® Forums

trailing spaces copying data from result set


#1

select * from <table_with_varchar2_columns>;
select several rows (or entire varchar2 column), copy, and paste (for example to notepad). It seems every row is padded to its max length with spaces??
This is the most annoying bug for me still in 5.5, but there the spaces come only after numbers. Now here, in 6.2 beta, copying numbers produces no spaces, but copying varchar2 does a ton

Andres


#2

Hi Andres,

Have you tried the preference Code Editor > SQL scripts > Trim column width while pasting?

Gwen


#3

Yes,
both Code Editor -> SQL Scripts -> Trim column width while pasting and General -> Object Editors -> Table Editor -> Trim column width while pasting are checked.

Andres


#4

Strange! It works fine for me. Could I please have the extracted ddl for this table? Thanks.


#5

create table debug_table
(sessioon varchar2(30 byte),
kasutaja varchar2(30 byte),
aeg timestamp (6),
tekst varchar2(4000 byte),
pakett varchar2(100 byte),
votmesona varchar2(100 byte))
/

i’m trying to copy column “tekst” - the length of the text is rarely less than 10 characters, 40 is average, but there are also a few lengthy lines (up to 1500 currently).

Another copy problem:
When i do a select that takes out a number of lines (say 7000), then executing select * from debug_table is fast, fetch all is fast, right-click on tekst column -> select column is fast, right-click => copy is sloooooow. It takes about 5 seconds before the mouse cursor changes to busy. With about 2000 rows it takes ~5 seconds to copy, with 7000 rows 130 seconds (yes, more than 2 minutes).

Andres


#6

Just tried it and couldn’t reproduce. This may be vain but could I have a screenshot please?

If copy takes that long, why not try export? Nonetheless, I will look into this for you tomorrow.

Cheers,
Gwen


#7

Hi Andres,

I tried with 20, 000 records but didn’t see any delay. But they’re only dummy data so it may not entirely fit your scenario.

Gwen