Toad World® Forums

Trigger Editor toolbar


#1

First, kudos for the new trigger editor. I think it is a better use of space than the old one. I am having an odd, but annoying issue where when I am creating a trigger, the toolbar comes up as off so there is no button to commit it to the database. It’s easy to right click and select show toolbar, but is there some trick I’m missing to get it to come up each time with the toolbar already on?


#2

Hi,
could you take a screenShot, I tried reproduce your issue, but with no success.
By the way, Creating, saving Triggers it’s DDL operation, commit is unnecessary

P.


#3

Yeah, I was using commit as a way of saying save to the database rather than commit in the DML sense. In taking the screen shots (attached), I toggled the Pin setting and now, the toolbar seems to be more willing to hang around. I don’t actually see any difference in the window with it pinned or not pinned when creating a new trigger, but it seems to have gotten the toolbar to come back when I shutdown SQL Nav and start it again.
new_trigger2.png


#4

Yeah, I was using commit as a way of saying save to the database rather than commit in the DML sense. In taking the screen shots (attached), I toggled the Pin setting and now, the toolbar seems to be more willing to hang around. I don’t actually see any difference in the window with it pinned or not pinned when creating a new trigger, but it seems to have gotten the toolbar to come back when I shutdown SQL Nav and start it again.


#5

Mark, You are right, creating trigger, launch old editor, editing triger, launch the new one, in code Editor.
SqlNav Team musl look at this.

P.


#6

Hi Mark,

I’ve reproduced the issue. It will be fixed in the next Beta build.

Regarding Piter’s comment that creating a trigger bring up the old trigger editor, it’s by design.

Regards,
Roman

PS. To bring back the toolbar, right-click trigger editor and toggle the ‘Show toolbar’ option.

Message was edited by: roman


#7

Thanks Roman – Yeah, I figured out the show toolbar trick and that definitely works so there is a valid workaround. Just wanted to mention it to the team. I’m impressed you’re still getting stuff in the beta.


#8

Hi Mark,

Thanks for getting back to us regarding the work around.

We have re-valuated this issue since Roman’s post. As we have a valid around and our team believed that our users would figure out the right click as you have indidated, and it is late for this change to get into the final build and we will get this issue addressed for you in early 6.4 Beta build.

We have done the final beta build to address a number of urgent issues found during our testing in the areas of code test and trigger editor working with team coding…We will try to send to build to you all in a few hours time.

Thanks and regards,
Bruce


#9

Makes perfect sense to me. Has a valid and relatively intuitive workaround, so bump it to the next beta unless that hunk of code were being touched to fix something else already. It’s been my first experience beta testing SQL Nav despite having the program for ages. I’m looking forward to 6.3’s release and contributing to the 6.4 beta process.


#10

Hi Mark,

Many thanks again for your feedback and support from all of us.

Regards,
Bruce


#11

Hi Mark,

We would like to let you know that we need to fix an issue found internally in the Trigger editor area so Roman has also fixed this the tool bar issue for you. The changes are in build 1828.

Thanks,
Bruce


#12

In build 1828 (having uninstall the previous build) I still had the problem that the create trigger editor didn’t had the toolbar displayed.
Reading this thread I found out the “show toolbar” option (old editor), but I found it strange to have it hidden by default.

Regards


#13

Hi Filipe,

I tested a clean install and it worked fine. You might have the settings in registry which hides the toolbar in previous build so the new build didn’t work correctly. This won’t be an issue after you turn it on manually.

Thanks,
Vincent