Toad World® Forums

Trouble inserting rows using table grid


#1

Hello,
some things that caught my eye.

  1. in code editor, where updateable is ON,
    when doing select * from small_table, where id defined as primary key and is populated from trigger (sequence)
    can’t add two rows together (by pressing “+”-button (add data), entering data and right away clicking the “+” button again, and enter the data for the second row. Re-execute the query and get

ORA-01407: cannot update (""."

"."") to NULL

If i add 1 row, then re-execute, then i can add another row (and the id gets nicely populated)

  1. When adding a new row to a table with a “+” button, filling the fields with space (inline), when all necessary fields are filled, the last field is still active from typing, hit commit button - the row is saved, but the field that was active when commit pressed is empty.

Thanks,
Andres

Message was edited by: Andres


#2

Hi Andres,

regarding to point 1:
This is not new in the Beta.
I avoid this issue by simply entering an arbitary value, 0 for example.
When doing it this was you have no problems anymore (at least regarding to this issue) :-).

Andre


#3

Hi Andre,
it may not be new in Beta - the 864 is practically the first beta for me, but they sure have fixed this in 5.5.x - i just tried in 5.5.4, and got no error, but two nice records :slight_smile: And there are also a couple of tables that take the value when given, and when not given, then take it from sequence - and this makes the workaround not so very nice. So let’s hope this gets fixed in 6.0 too.

But thanks for your reply anyway,
Andres


#4

Hi Andres,

I believe there might be two things that caused the problem:

-Because of the nature of the data grid, when you enter a new value you need to press enter at the end for that value to be recognized. Else it would be considered as empty which may lead to the problem where you tried to add new record and the field is null although a value has been put in. So, before you press “+” to add another record, make sure you press enter after entering the data.
-The table may not be updated because you havent commit before executing the query again.

Hope this helps

Gwen