Toad World® Forums

.txp file saved in Team Foundation Server


#1

I don’t think this is a Quest issue but I am wondering if anyone has seen this and may have a workaround…we are changing Source Control systems from SourceGear Vault to Microsoft Team Foundation Server. When I try to view a .txp file saved in TFS the Source Control Explorer is treating it as an XML file (which technically it is) and opening it with an XML Editor in Visual Studio. Obviously I would like for the file to open with its default Program (yes I did verify TDM still shows as default program in Windows). I have been searching through the Options in Visual Studio and have not found a way to over-ride this default behavior, any ideas or suggestions would be appreciated. Thanks!


#2

Hello,

It’s not a TDM issue. From what you write, it seems that some programs you use cause it.
We’re sorry, we don’t have a tip for you to solve it. Sorry.

Regards,

Vladka + TDM Team


#3

Correct, it is a Team Foundation Server issue and I was able to get the answer from Microsoft which is as follows;
" This can be done in Solution Explorer. And then in source control explorer it will use your program to open the file. Add a sample .txp file to a solution, Right Click it=>Open With…, on the Open With Dialog, click “Add” and choose your external tool and set as default."

Just in case anyone else runs into this problem the above solution does work.

-RJ


#4

Perfect! Happy to hear it’s solved.
Thanks for sharing.

Regards,

Vladka