Toad World® Forums

UE autotrim


#1

In the UE editor, it looks like each line gets all the trailing spaces trimmed as soon as you leave the line.
When you type in a select statement, like:
SELECT first_name, middle_name, last_name
FROM mytable

Then type in
WHERE (with a space or two here)

Then go up to your select to copy a fieldname, like last_name, and paste it back on your WHERE statement, there is no more space after WHERE, so it looks like:
WHERElast_name

You have to go back and add the spaces again.

Thanks.
-Charlie


#2

True. The default behavior of the editor component is to remove all the trailing spaces. We can disable this behavior and trim the spaces only when the text is actually saved (e.g. to database). I assume this shouldn’t affect the performance.

Regards,
Roman


#3

Hi Charlie,

This issue is also fixed (much better now).

  • Jaime -

#4

yes, much better now. Thanks.