Toad World® Forums

Update of Formatting options


#1

If you modify the Formatting Options, and then try to Save, you get:
Internal error occurred; see file ERROR.LOG for details

Thanks.
-Charlie


#2

Hi Charlie

I assume you are using the latest beta correct?

On many occasions during development I was able to get the same Internal Error as yourself, but we have fixed it each time. With he latest beta I am not able to reproduce this.

Can you give me an example of 1 change you make that causes the error?
Perhaps its an edit to a particular formatter option that is causing it.

thanks
Lidia


#3

I am using version 7.0.0.2814.

Click on formatting options (from the toolbar). In the Header section (very first option), change from Enable to Disable (or Disable to Enable). Then Save. You will get the Internal Error in the Output window. You can’t save it.

Thanks.
-Charlie


#4

Hi Charlie,

Can you read the path of FmtOptions.opt/FmtOptions.xml from the title bar of this options window? What is it?

Also please try to use File | Save As to specify another location to save the options. Let me know if that helps.

Thanks,
Vincent


#5

It looks like it is saving it to *\Quest Software\SQL Navigator 6.7.0\FmtOptions.opt. Not sure why it is going to 6.7, I’m using the 7.0beta. I tried Save As and went to my “SQL Navigator 7.0.0 Beta” directory, and i still get the ERROR.LOG error. Then I tried saving it to my desktop, and I got the issue again.

Thanks.
-Charlie


#6

Hi Charlie,

Could you use Help | Create Support Bundle Files to generate support bundle and profile data? Please send both SupportBundle.dat and SupportBundle.prof to my email Vincent.Liu@quest.com.

Thanks,
Vincent


#7

This is still an issue for me with the new beta. I can’t update my formatting options at all.

Thanks.
-Charlie


#8

Hi Charlie,

I’m sorry for the very late response. I just found out the profile you sent me and I could reproduce the error now. PT49818375 is created for this. I will fix this assp.

You can also fix the error by reloading the opt file following the steps below:

  1. close sqlnav;
  2. delete HKEY_CURRENT_USER\Software\Quest Software\SQL Navigator 7.0.0 Beta\Formatter\Formatter_Options_Path;
  3. rename C:\Users\Wancio\AppData\Roaming\Quest Software\SQL Navigator 7.0.0 Beta\fmtOptions.opt to fmtOptions_bak.opt;
  4. open sqlnav;
  5. open formatter options window, and then use its Open dialog to open C:\Users\Wancio\AppData\Roaming\Quest Software\SQL Navigator 7.0.0 Beta\fmtOptions_bak.opt
  6. now you should be able to update formatter options and save it at will.

Thanks,
Vincent