Toad World® Forums

User Package Path not found


#1

During startup a message box shows up:
User package path doesn’t exists
user packages will not be loaded

This is caused because the 2 backward slashes ‘\’ are missing in the full path
the path in the messagebox is
servername\sharename\username\Toad Data Modeler\Packages{GUID}
this should be
\servername\sharename\username\Toad Data Modeler\Packages{GUID}

Raymond


#2

Raymond,

Thanks again! As soon as I know more, I’ll get back to you.

CR # 27 975.

Vladka


#3

Hi Ramond,

Let me ask you a few questions on your User packages.

  1. What is the path to packages defined in the Settings menu | Options | Paths | Path to Packages?

  2. Does the path defined there physically exist?

  3. Please open the directory with the packages and check out if User package exists there.

(Example: My path to my user packages:
C:\Documents and Settings\vnitrova.PROD\My Documents\Toad Data Modeler\Packages{DCB5CB9B-CF65-4350-86B5-285D246FC5AC})

Thanks for checking it out!

Vladka


#4

Hi,

I am having the same problem.
My Observations and a Questions are below.

  1. What is the path to packages defined in the Settings menu | Options | Paths | Path to Packages?
    I cannot see anything in the Options Dialog because I get many messages of the variety. “Error during loading form definition 'TfrConfigApplicationPath”

  2. Does the path defined there physically exist?
    No Path is set in the Options Dialog

  3. Please open the directory with the packages and check out if User package exists there.
    Yes:
    “\pisgana01sent00\en04gb09$\stebrown\My Documents\Toad Data Modeler\Packages{DCB5CB9B-CF65-4350-86B5-285D246FC5AC}”
    and as others have noted, The message is messing the leading “\”

Attached is the user.txg file from the above directory

More information:
4) C:\Program Files\Quest Software\Toad Data Modeler - Beta 3\Packages\System\MetaModels
Exist and appears to be populated.

  1. C:\Program Files\Quest Software\Toad Data Modeler - Beta 3\Packages\User
    Exist and the user.txg is the same the one in the “My Documents…” Path

QUESTION: Is there a list of what features are supported or am I to assume that it is fully functional (with defects/etc) but only supports Oracle. My Functionality seems very limited, I assume based on the fact that is an issue with the options/setting and packages.Is this a correct assumption?

EDIT: I found the BETA feature matrix, and my limited functionality would appear to be issue related.

Thanks

Message was edited by: bvader
user.txg (494 Bytes)


#5

Hi,

Thanks very much for the information.
This is caused because the 2 backward slashes ‘\’ are missing in the full path.
This is a bug - CR # 27 975.

To be able to work with BETA until the bug is fixed, please follow these steps:

  1. Uninstall BETA and delete ALL TDM BETA directories (all user and system files, paths to them).
  2. Install BETA from scratch.
  3. Do not change the TDM BETA paths.

Thanks!

Vladka & TDM Team


#6

I followed you instructions. Same Problem.

I installed the product only using defaults. I did not change any path However, My “My Documents” Directory is not on a local drive it is on a network drive per my IT group. I did not set it to a network path, I have no choice.

I suppose I will need to wait until the CR is fixed thanks.


#7

Hello,

Yes, please wait until the bug is fixed.
We’re working on this issue.

Thanks very much for your patience!

Vladka


#8

I have 3.6 version installed and still facing same issue; My Document folder is on network drive;

How to change to local folder

I modified all properties in options but still point to network drive…


#9

Hi,

in Settings | Options click the Paths section and on tab Advanced see Path to packages value.

Open the folder and copy all packages to another local folder. Then change the value of Path to packages to the local folder and restart TDM.

Regards,

Vaclav