Toad World® Forums

Version 3.1.0.315 cannot display table columns


#1

I was using the freeware version 3.0.0.129 without any issue, until the 1 year expiration. I was prompted to download the latest (2016) version 3.1.0.315.

Upon installation, I immediately found out, while the new version inherited the saved connections, when I connected to the server, it only lists the table names, but cannot retrieve the column definition that normally shows in the bottom of Object Explorer. Instead, I got error message

“Attempt to insert NULL value into column 21 in work table (table id 4288282623); column does not allow NULLS. UPDATE fails.”

I found if I close Toad for SAP and restart, the same error message will show up except with a different table id. I tried to use object_name() to get the work table name, only to get Sybase Database Error “Arithmetic overflow during implicit conversion of BIGINT value ‘4288282623’ to a INT field .”

I suspect it’s some script for creating the work table. I even copied the script from Tools --> Options --> SQL Dictionary --> Db.CommonSql --> DescribeTableColumns from the old version 3.0.0.129. I found it is the same as the new version. I could run the script in 3.0 before, but when I created an editor and pasted the script and run, the very same error message “Attempt to insert NULL value into column 21 in work table (table id 4288282623); column does not allow NULLS. UPDATE fails.” shows up.

The target SAP is ASE 16. On another connection to a ASE 15.7 server which the old 3.0 version had no issue on, it will connect to the server but no table will be listed. If I right click at the table area and select Refresh from the drop down, I will get an error “Invalid column name ‘sysstat4’”.

Is there any way to let me keep using the old but working version 3.0.0.129, instead of the 3.1.0.315? Or is there any way (such as updating the script) so the work table’s column 21 can allow NULL value? In the current state it is not usable.

Thanks!


#2

Hi, I am really sorry about problems which you have. I saw this problem before (but on different place) and it was related to SAP client which we are using for communication with server. We updated this client in our latest version 3.2. For now would be great if you can try it and verify problem there.

About problem with ‘sysstat4’ seems that you are trying to run SQL for ASE16 only. Can you check SQL in SQL Dictionary for ASE15.7 -> CommonSql -> ListTables ? We are using this field for getting information about Index Compression which is not supported in previous version.

Filip


#3

Thank you very much Filip.

The suggestion on ListTables does do the trick. I managed to copy the ASE 15.7 version from the older V3.0 and it worked for V3.1.

However the biggest issue is still the first one related to DescribeTableColumns with the error message “Attempt to insert NULL value into column 21 in work table (table id 4266590158); column does not allow NULLS. UPDATE fails.” This prevents me to basically do anything with the DB. I am glad this problem was observed before and fixed in version 3.2, but I do not have the power to convince the client to purchase a commercial license yet (Sybase/ASE is only for a small legacy system with the client) and the free version is not available. Would the community version be available any time soon? The current 3.1 was released in May, 2016.

It seems that I installed the 3.0.0.129 version on 7/8/2016. I saw a prior post in the forum someone cleared the profile and reinstall the older version. Is that the only way to extend the usage of version 3.0? It worked very well and had everything I needed. I would gladly install v3.2 when a freeware version becomes available.

Thanks!


#4

I believe you can download our 3.2 update and part of this installer should be also Trial/Freeware version. You can also try out our Beta for version 3.3.

Filip


#5

Thanks Filip!

One problem exists: when clicking on the Upgrade (V3.2) link from Toadworld, it redirects to quest.com’s main site, with the message

“Customers under current support maintenance contract can download their relevant installation below”. It needs an Asset number which I do not.

The other links, Trial and Freeware, both are V3.1.

However, I am able to download V3.3 Beta, and it does seem to have resolve the issues. There is an expiration date of 10/10/2017, so I just hope by that time V3.2 freeware is available. Or, can you instruct me where the current V3.2 can be downloaded, without the asset number information?

Thank you very much for your help!!


#6

I staged TSAP 3.2 trial below.

http://community-downloads.quest.com/toadsoft/SAP/ToadforSAP_3.2.0.96.zip

Please download


#7

Thank you very much Debbie!

This indeed resolved all the issues I encountered with Version 3.1!

Truly appreciate you posted the direct download link.

Thanks again!


#8

Hi Debbie,

Today when I was opening TSAP3.2 (3.2.0.96) I am getting the error message “Please enter a license key and site message”.

Is there a newer version of trial available? A direct download link will be greatly appreciated!

Thanks!

Deewen

On Thu, Jul 13, 2017 at 4:32 PM, Debbie Peabody bounce-Debbie_Peabody@toadworld.com wrote:

RE: Version 3.1.0.315 cannot display table columns

Reply by Debbie Peabody
I staged TSAP 3.2 trial below.

http://community-downloads.quest.com/toadsoft/SAP/ToadforSAP_3.2.0.96.zip

Please download

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or Unsubscribe from Toad for SAP Solutions Forum notifications altogether.

Toad for SAP Solutions - Discussion Forum

Flag this post as spam/abuse.


Deewen Wu
410-963-3755


#9

Here Try this.

License Key: BDQLFG3THXLKHL52XUSKZFNKZ4MAS42H5YDYKXX1-123-456-789-51

SiteMessage: Trial Version


#10

Help!

Had been using this Freeware licence key for exactly a month (in case that’s relevant!) but today I’m being told “License key or site message invalid”.

Trying to use 3.2.0.110

Is there anything I can do (apart from get my employers to pay something)?

Thanks!


#11

The license key was for a trial version. When that expires it should revert to Freeware which is subset of the features. Are you able to start the product and connect?


#12

Hello Debbie

Thanks for your response.

No, I’m faced with the screen below (“Continue” dimmed).

Can’t see any way to progress


#13

Can you try uninstall and install it again? Also can you check what start splash screen say about your license? I have no license installed and I see correctly Freeware.
image
Thanks

Filip


#14

Yes, thank.

Looks like it was originally installed by an Administrator; this time by me.