Toad World® Forums

Viewing package body in SchemaBrowser hang Toad, both 13.2 and 13.3

We have a few packages that hang Toad when we try to view the body in schema browser.
It also hang when we try to doubleclick it and open to editor.
Toad hang and the pc's cpu is running high.
We had the problem first in Toad 13.2 and have been waiting for 13.3, but the bug still persists in 13.3.


Do you use utPLSQL or have it installed and accessible to the connected schema?

No, we do not use utPLSQL

I was reminded of a similar issue that has been logged with us regarding mixed usage of tabs and spaces causing hangs. Check your code and if tab char and space chars are both being used for indentation, change your tabs to spaces, recompile, and check the behavior.

Replacing all tab withs spaces in the package body solved the problem yes.
Using Edit --> Format Code in Toad removed all the tabs, so it was just to compile after formating and it worked fine in Toad 13.2 and Toad 13.3.

It is still a bit strange that our code is working fine in Toad 13.1 but not in 13.2 and 13.3.
So i would still consider it as a bug, but with this solution as a workaround :slight_smile:
Thanks for yout help!


This should be fixed in the beta just released.