Toad World® Forums

Window Vista and SQL-Navi Problem when "save as" onto a Novell volume


#1

Hello down under,

long time ago that you have heard from me…
My colleague Alex has a Problem with Window Vista and SQL-Navi (both 5.5.2 and the latest 6.0 Beta too)
If he makes an extract DDL and want to save the content as a file on an des Novell-Server SQL Navi pretends the file is saved correctly but it does not.
The file has in the end a length of 0 byte. Not really a much content :slight_smile:

He noticed this first on Version 5.5.2 and I gave him the Beta to check if the same happens. And yes - it is the same error.
Saving the DDL on a local drive is not at problem at all and works as expected. He has tested these save a file stuff with a lot of other programs and non of them has had any problem.
So it seems this is a SQL-Navi bug.
I’m sorry, but I cannot verify this since I don’t have a Vista running.
Alex of course has – he likes new toys …

His Konfiguration:
· Navigator 5.5 oder 6.0 Beta
· Vista Ultimate 32 Bit
· Novell-Client for Vista (Beta)

Best Regards
Andre

Message was edited by: andreml


#2

Hi Andre,

Thank you very much for submitting the feedback on SQLNAV6.0 Beta. Here we have tested SQLNAV 6.0 Beta on Windows Vista and we have not had any problems in file saving etc.
We support Citrix environment as well.

We observed from your post that yourself and your colleague are using Novel environment which we don’t have in our test lab. But if you can provide more information about the Novel client/Novel server version you are using and the user permissions as well. We try to create similar environment to yours and try to investigate further. Please also provide the details about the server operating system.

You have mentioned that other programs can save a file to Novel server. Can you please confirm that the file from windows (ANSI) notepad can be saved to Novel server with the same user who tried to save from SQLNAV.

We are also interested to know how common it is to use Novel client/Server configuration in your work environment.

regards
sekhar


#3

Hello Sekhar,
This is what Alex sent me with regard to your questions :

Novel-Client please see: http://www.novell.com/beta/auth/beta.jsp?id=2306&type=1

Novell 6.0: No file exists: Error messages: “Unable to save file. Access is denied.”
Save with Ultraedit from same workstation => ok.
Back in Nav 6.0 and Save as => File content is changed
That means if a file allready exists SQLNav can overwrite it, but not create a nwe one.

Novell 6.5: No file exists: Save is posible. File ist written with 0 Byte !
Save with Ultraedit from same workstation => File ist written with content
Back in Nav 6.0 and Save as => Nav is asking for override => Yes.
The File (with content) ist overwritten with 0 Byte. That’s a really critical case !

Novell is the main Server OS in our environment, since it is installed on all File servers.

I hope that hepls.
Regards
Andre

PS: I have forgotten to notice: To save something as file from the data grid works with no problem. But there is on other issue. Please see the separate messages for that.