Toad World® Forums

6.5 - PostgreSQL 9.5 why is autovacuum automatically added to each entity?


#1

We have autovacuum set up at the database level and don’t want references to autovacuum_enable to appear at the entity level?

The checkbox under “Storage Parameters” was checked by default and added WITH (autovacuum_enabled = true). Unchecking the box, changes it to false but we don’t want it in the DDL script at all.

Additionally, do you have any idea as to when Toad Data Modeler can import PostgreSQL DDL scripts?

Thank you,
Steven Smith


#2

Hello Steven,
Import PostgreSQL DDL script is possible from Toad Data Modeler 6.5. It is implemented only for PostgreSQL 9.5 and PostgreSQL 10.

TDM generate autovacum parameter in DDL script always, but it is possible make some customization to change this behavior. I can do it for you. Let me know your TDM version and PG versions(Presume PG 9.5) and I’m able to prepare for you tdm package.

best regards
Daril


#3

Thank you very much.

TDM 6.5.5.6

PostgreSQL 9.5

Steven Smith

System Architect - Contractor, Division of Federal Systems

Office of Child Support Enforcement

Administration for Children and Families, U.S. Department of Health and Human Services

330 C St. SW, Washington, DC 20201

steven.smith@acf.hhs.gov |443-436-6449


#4

Using TDM 6.5.5.6, launch new connection, go to DDL Script RE but I don’t see any PostgreSQL version listed?

I only had 9.5 checked. Once I checked PG 10 then PG 9.5 and 10 showed up in the list.

Steven Smith

System Architect - Contractor, Division of Federal Systems

Office of Child Support Enforcement

Administration for Children and Families, U.S. Department of Health and Human Services

330 C St. SW, Washington, DC 20201

steven.smith@acf.hhs.gov |443-436-6449


#5

Hello Steven,
here is link to TDM package
https://dl.bintray.com/quest/ToadDataModeler/Forum/Generator_Autovaccum_PG95.txg?expiry=1771681200000&id=IRrec6NpYhLV52JsVcWVBAsl%2BE9REFOeWMVypt8PzT0%3D&signature=aWKVB%2Fo5IwvQ5J7e2l2V5ppmKvc4dxNsRMm8FR2UIiGP73XuZNK3GRSnTWa13xHbnPb9V%2BGduzjgC2%2FcrAXHdA%3D%3D

How to import custom package to TDM:

  1. Go to Settings-Options-General and Select Expert Mode
  2. Go to Expert Mode - Customization - Import Custom Package
  3. Select Package
  4. Restart TDM

In this package I disable generate autovacuum when is set unchecked checkbox. If you want to disable it every time it easy modification in this package. Just open Package Explorer(Expert Mode), find pacakge “Generator_Autovacuum_PG95” and in this pacakge is located script “PERCodeGeneratorPG95_2”. Doubleclick on this script open script editor and you can modify behavior of generator.

Daril


#6

Thank you.

Steven Smith

System Architect - Contractor, Division of Federal Systems

Office of Child Support Enforcement

Administration for Children and Families, U.S. Department of Health and Human Services

330 C St. SW, Washington, DC 20201

steven.smith@acf.hhs.gov |443-436-6449


#7

I tried to reproduce your problem with missing import of DDL script, but I’m not successful. I have clear installation and enable only PG 9.5 and I see import DDL PG 9.5 datasource.

I guess your state could have happened after upgrading from the older version. I hope that now it will be OK for you.

best regard
Daril